New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Activate entity regression on nodm7 #248

Open
zturtleman opened this Issue May 18, 2016 · 5 comments

Comments

3 participants
@zturtleman
Owner

zturtleman commented May 18, 2016

Activate entity regression on Claustrophobopolis 2003 reportedly caused by zturtleman/mint-arena@f10b087...116ec08 changes for #220.

@zturtleman zturtleman added this to the Spearmint 0.4 milestone May 18, 2016

@coltongit

This comment has been minimized.

Show comment
Hide comment
@coltongit

coltongit May 21, 2016

Does zturtleman/mint-arena@cdaef49 fix this, @zturtleman? Could be a potential fix to this activate entity bug. EDIT: I have confirmed that bots activate entities on that map just fine with that mint-arena revision, @zturtleman. It seems you have already fixed this regression with the latest change to entity activation.

coltongit commented May 21, 2016

Does zturtleman/mint-arena@cdaef49 fix this, @zturtleman? Could be a potential fix to this activate entity bug. EDIT: I have confirmed that bots activate entities on that map just fine with that mint-arena revision, @zturtleman. It seems you have already fixed this regression with the latest change to entity activation.

@KuehnhammerTobias

This comment has been minimized.

Show comment
Hide comment
@KuehnhammerTobias

KuehnhammerTobias May 23, 2016

Contributor

Who do you have confirmed? Nevertheless, I can't confirm that zturtleman/mint-arena@cdaef49 will fix the activate bug. Though, activating isn't really the problem, bots loose their NBG/LTG after activating. Most noteable next to the secret door to RA.
Still busy, I'm working on it...

Contributor

KuehnhammerTobias commented May 23, 2016

Who do you have confirmed? Nevertheless, I can't confirm that zturtleman/mint-arena@cdaef49 will fix the activate bug. Though, activating isn't really the problem, bots loose their NBG/LTG after activating. Most noteable next to the secret door to RA.
Still busy, I'm working on it...

@coltongit

This comment has been minimized.

Show comment
Hide comment
@coltongit

coltongit May 23, 2016

Best thing to do is to check and see if it's fixed or not, @KuehnhammerTobias.

coltongit commented May 23, 2016

Best thing to do is to check and see if it's fixed or not, @KuehnhammerTobias.

@zturtleman

This comment has been minimized.

Show comment
Hide comment
@zturtleman

zturtleman May 24, 2016

Owner

mm, yeah I'm thinking that Seek_LTG should pass Seek_NBG to the BotAIPredictObstacles and BotAIBlocked functions (I haven't checked this issue yet). Though, ultimately creating a Battle_ActivateEntity and not passing aienter function pointers around is probably best.

Owner

zturtleman commented May 24, 2016

mm, yeah I'm thinking that Seek_LTG should pass Seek_NBG to the BotAIPredictObstacles and BotAIBlocked functions (I haven't checked this issue yet). Though, ultimately creating a Battle_ActivateEntity and not passing aienter function pointers around is probably best.

@coltongit

This comment has been minimized.

Show comment
Hide comment
@coltongit

coltongit May 25, 2016

I agree with the battle_activateentity approach, @zturtleman.

coltongit commented May 25, 2016

I agree with the battle_activateentity approach, @zturtleman.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment