Still seeing $base_size issue #828

Closed
mearleycf opened this Issue Aug 24, 2012 · 8 comments

Comments

Projects
None yet
4 participants
@mearleycf

Syntax error: Function ms is missing argument $base_size.
on line 7 of /foo/.compass/extensions/zurb-foundation/stylesheets/foundation/common/_globals.scss
from line 1 of /foo/.compass/extensions/zurb-foundation/stylesheets/foundation/common/_base.scss
from line 14 of /foo/.compass/extensions/zurb-foundation/stylesheets/foundation.scss
from line 5 of /foo/Dropbox/Documents/bar/sass/app.scss

I followed ticket #788 already...

mike-imac:dreamer_justice_fix mike$ compass install -r zurb-foundation foundation/upgrade --force
error sass/app.scss (Line 7 of _globals.scss: Function ms is missing argument $base-size.)
overwrite stylesheets/app.css
error sass/archive/app.scss (Line 7 of _globals.scss: Function ms is missing argument $base-size.)
overwrite stylesheets/archive/app.css

I'm still seeing this. I did do the gem updates also (to 3.09, modular scale 1.0.2).
Updating installed gems
Updating chunky_png
Successfully installed chunky_png-1.2.6
Updating sass
Successfully installed sass-3.2.1
Updating zurb-foundation
Successfully installed sassy-math-1.2
Successfully installed modular-scale-1.0.2
Successfully installed zurb-foundation-3.0.9
Gems updated: chunky_png, sass, sassy-math, modular-scale, zurb-foundation
Installing ri documentation for chunky_png-1.2.6...
Installing ri documentation for sass-3.2.1...
Installing ri documentation for sassy-math-1.2...
Installing ri documentation for modular-scale-1.0.2...
Installing ri documentation for zurb-foundation-3.0.9...
Installing RDoc documentation for chunky_png-1.2.6...
Installing RDoc documentation for sass-3.2.1...
Installing RDoc documentation for sassy-math-1.2...
Installing RDoc documentation for modular-scale-1.0.2...
Installing RDoc documentation for zurb-foundation-3.0.9...

@plankguy

This comment has been minimized.

Show comment Hide comment
@plankguy

plankguy Aug 25, 2012

Getting the same errors. Running:

modular-scale (1.0.2)
ruby 1.8.7
Compass 0.12.2
Sass 3.2.1

I get this error when updating zurb-foundation:

ERROR: Error installing zurb-foundation:
modular-scale requires RubyGems version >= 1.3.6

When I try force upgrading (ompass install -r zurb-foundation foundation/upgrade --force) I get:

error scss/app.scss (Line 7 of scss/foundation/common/_globals.scss: Function ms is missing argument $base-size.)
identical stylesheets/app.css
error scss/foundation/functions/modular-scale.scss (Line : An @import loop has been found: /Volumes/Dev/Lightermail/riverdale/static_test/scss/foundation/functions/modular-scale.scss imports itself)

Getting the same errors. Running:

modular-scale (1.0.2)
ruby 1.8.7
Compass 0.12.2
Sass 3.2.1

I get this error when updating zurb-foundation:

ERROR: Error installing zurb-foundation:
modular-scale requires RubyGems version >= 1.3.6

When I try force upgrading (ompass install -r zurb-foundation foundation/upgrade --force) I get:

error scss/app.scss (Line 7 of scss/foundation/common/_globals.scss: Function ms is missing argument $base-size.)
identical stylesheets/app.css
error scss/foundation/functions/modular-scale.scss (Line : An @import loop has been found: /Volumes/Dev/Lightermail/riverdale/static_test/scss/foundation/functions/modular-scale.scss imports itself)

@plankguy

This comment has been minimized.

Show comment Hide comment
@plankguy

plankguy Aug 26, 2012

After a lot of pluggin' away, I found the answer to my issue here:

http://stackoverflow.com/questions/1954206/cant-update-rubygems

I'm new to this whole thing, but it seemed that modular-scale was causing all the issues for me, so once I re-installed it successfully, things worked. Last;y I had to comment out @import "modular-scale"; in modular-scale.scss as it was causing an @import loop.

After a lot of pluggin' away, I found the answer to my issue here:

http://stackoverflow.com/questions/1954206/cant-update-rubygems

I'm new to this whole thing, but it seemed that modular-scale was causing all the issues for me, so once I re-installed it successfully, things worked. Last;y I had to comment out @import "modular-scale"; in modular-scale.scss as it was causing an @import loop.

@mearleycf

This comment has been minimized.

Show comment Hide comment
@mearleycf

mearleycf Aug 26, 2012

Hmm...so I uninstalled and re-installed modular-scale...

mike-imac:bin mike$ sudo gem uninstall modular-scale

You have requested to uninstall the gem:
modular-scale-1.0.2
zurb-foundation-3.0.9 depends on [modular-scale (>= 1.0.2)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] y
Successfully uninstalled modular-scale-1.0.2
mike-imac:bin mike$ sudo gem install modular-scale
Successfully installed modular-scale-1.0.2
1 gem installed
Installing ri documentation for modular-scale-1.0.2...
Installing RDoc documentation for modular-scale-1.0.2...

and opened _all.scss within the compass directory, commenting out //@import "modular-scale" as you suggested, but am still seeing the same issue.

Hmm...so I uninstalled and re-installed modular-scale...

mike-imac:bin mike$ sudo gem uninstall modular-scale

You have requested to uninstall the gem:
modular-scale-1.0.2
zurb-foundation-3.0.9 depends on [modular-scale (>= 1.0.2)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] y
Successfully uninstalled modular-scale-1.0.2
mike-imac:bin mike$ sudo gem install modular-scale
Successfully installed modular-scale-1.0.2
1 gem installed
Installing ri documentation for modular-scale-1.0.2...
Installing RDoc documentation for modular-scale-1.0.2...

and opened _all.scss within the compass directory, commenting out //@import "modular-scale" as you suggested, but am still seeing the same issue.

@hatefulcrawdad

This comment has been minimized.

Show comment Hide comment
@hatefulcrawdad

hatefulcrawdad Sep 4, 2012

I'm not sure how to reproduce this on my machine. How many still seeing this issue? Can anyone erase all instances of gems and take a screencast of their process? Or just bullets would work too if you are detailed enough.

I'm not sure how to reproduce this on my machine. How many still seeing this issue? Can anyone erase all instances of gems and take a screencast of their process? Or just bullets would work too if you are detailed enough.

@kelicia

This comment has been minimized.

Show comment Hide comment
@kelicia

kelicia Sep 7, 2012

Contributor

I am having the same issue but I am very very new to foundation/sass etc so I don't think i can help figure out a solution.

Contributor

kelicia commented Sep 7, 2012

I am having the same issue but I am very very new to foundation/sass etc so I don't think i can help figure out a solution.

@144288 144288 referenced this issue in modularscale/modularscale-sass Sep 14, 2012

Closed

Problem with codekit #29

@hatefulcrawdad

This comment has been minimized.

Show comment Hide comment
@hatefulcrawdad

hatefulcrawdad Sep 18, 2012

Is this issue still present if you start a fresh project with version 3.1?

Is this issue still present if you start a fresh project with version 3.1?

@kelicia

This comment has been minimized.

Show comment Hide comment
@kelicia

kelicia Sep 18, 2012

Contributor

I haven't tried a new project yet but I did discover that the issue was related to my compass.app install.

https://groups.google.com/d/topic/foundation-framework-/VanneIh2PuU/discussion

*edit: fixed link

Contributor

kelicia commented Sep 18, 2012

I haven't tried a new project yet but I did discover that the issue was related to my compass.app install.

https://groups.google.com/d/topic/foundation-framework-/VanneIh2PuU/discussion

*edit: fixed link

@hatefulcrawdad

This comment has been minimized.

Show comment Hide comment
@hatefulcrawdad

hatefulcrawdad Sep 18, 2012

Okay, I'll close this issue for now since its related to another issue.

Okay, I'll close this issue for now since its related to another issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment