Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Caption not showing up (Orbit) #1268

jartaud opened this Issue · 7 comments

6 participants


Can someone please check the line 6? I think this: (t=t.substring(1,t.length)) is screwing up the rest of code.
//Foundation.js, Orbit Plugin 1.4.0, FF 17.0.1 Ubuntu 12

1. setCaption:function(){
2.     var t=this.currentSlide().attr("data-caption"),n;
3.     if(!this.options.captions)return!1;
4.     if(t){
5.         if(e.trim(e(t).text()).length<1)return!1;
6.         t.charAt(0)=="#"&&(t=t.substring(1,t.length)) ,n=e(t).html(),this.$caption.attr("id",t).html(n);
7.         switch(this.options.captionAnimation){
8.             case"none":
9.                 this.$;
10.             break;
11.             case"fade":
12.                 this.$caption.fadeIn(this.options.captionAnimationSpeed);
13.             break;
14.             case"slideOpen":
15.                 this.$caption.slideDown(this.options.captionAnimationSpeed)
16.         }
17.     }else 
18.     switch(this.options.captionAnimation){
19.         case"none":
20.             this.$caption.hide();
21.         break;
22.         case"fade":
23.             this.$caption.fadeOut(this.options.captionAnimationSpeed);
24.         break;
25.         case"slideOpen":
26.             this.$caption.slideUp(this.options.captionAnimationSpeed)
27.     }
28. }

Just started using foundation, and I can corroborate that the captions are not showing up for me in the latest download (downloaded yesterday), which contains orbit 1.4. I've tried using the exact code that's on the playground site, which is running 1.2, and it doesn't work for me on 1.4. All that's displayed is an empty caption background, no text.


Just downloaded the current version (default css, 3.2.2) from and captions don't show up for me. Let me know if I can clarify anything about my environment that would make my input more useful.

Screen Shot 2013-01-01 at 12 51 04 AM

Update: problem exists in current Mac/Chrome and Mac/Firefox. There are no console errors in either browser.

Update 2: Ok so it looks like the vanilla download does show Orbit captions but the Custom CSS download does not...


Can anyone tell me which version of the gem I can revert to to make this work again?


I have the same problem with gem version 3.2.3. To have it work you can downgrade to the version 3.2.2, that is working for me :)


@mildfuzz Are you going to keep the repository updated?
Maybe you can do a pull request with all your updates :)


Submitted :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.