Building on Linux

Bruno Vernay edited this page Dec 19, 2018 · 7 revisions

IMPORTANT: this article is not 100% accurate, e.g. it assumes you use the X Window System.

If you consider yourself confident enough (and use a deb-based distro with apt-get), you can proceed to TL;DR, otherwise the detailed instruction is probably what you should proceed to.

Deb-based (Ubuntu, Debian, Mint..) TL;DR

The following has been tested on a fresh Ubuntu 16.04 (64-bit) install.

NOTE: If you have zynaddsubfx (or similar) package installed, you should remove it before executing the last command.

$ sudo apt-get install build-essential git ruby libtool libmxml-dev automake cmake libfftw3-dev libjack-jackd2-dev liblo-dev libz-dev libasound2-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libcairo2-dev libfontconfig1-dev bison
$ git clone https://github.com/zynaddsubfx/zyn-fusion-build
$ cd zyn-fusion-build
$ ruby build-linux.rb
$ tar -jxvf zyn-fusion-linux-64bit-3.0.3-patch1-release.tar.bz2
$ cd zyn-fusion
$ sudo bash ./install-linux.sh

NOTE: If you don't use JACK and use ALSA, you can run the software with zynaddsubfx -O alsa. Details in the help message: zynaddsubfx -h.

After building and installing is done, there should be standalone, LV2 and VST versions of Zyn-Fusion on your Linux machine.

'Detailed' instruction:

Everything below should be done in your terminal emulator as a normal user (not as root).

Dependencies

NOTE: if you have libfltk1.x (or similar package) installed, see this issue.

First of all, you will need to install the dependencies of Zyn-Fusion.

Deb-based

Following was tested on a fresh Ubuntu 16.04 (64-bit) install. The dependencies should suffice on other versions of Ubuntu and other deb-based distributions as well.

$ sudo apt-get install build-essential git ruby libtool libmxml-dev automake cmake libfftw3-dev libjack-jackd2-dev liblo-dev libz-dev libasound2-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libcairo2-dev libfontconfig1-dev bison python
Arch

The following was tested on a fresh (2018-01-06) Arch Linux install. The dependencies should suffice on Arch derivatives as well.

Instead of the last two packages different packages should be installed in some cases.

$ sudo pacman -S gcc ruby python pkg-config git make cmake automake autoconf bison libtool mxml liblo zlib fftw jack2 alsa-lib cairo glu mesa

RPM based

The following was tested on a Fedora 29. (Instead of the group @"C Development Tools and Libraries" you could install detailed packages gcc, make ... but the precise list is up to you.)

$ sudo dnf install @"C Development Tools and Libraries" git ruby libtool mxml-devel automake cmake fftw-devel jack-audio-connection-kit-devel liblo-devel zlib-devel alsa-lib-devel  libX11-devel  mesa-libGL-devel cairo-devel fontconfig-devel python bison

Cloning the repository

To build the software, you will need the build scripts, which are in this repository. To get, it clone the repository. After that, change your current directory to the cloned repository's one.

$ git clone https://github.com/zynaddsubfx/zyn-fusion-build
$ cd zyn-fusion-build

Executing the build script

To execute the build script, which is written in Ruby programming language, execute the following. It will ask you for superuser password one or several times.

$ ruby build-linux.rb

When finished, it should generate demo and release tarballs (archives) that contain Zyn-Fusion.

Installation

NOTE: If you have zynaddsubfx (or similar) package installed, you should remove it before executing the last command.

Unpack the tarball, change your current directory to the unpacked folder, execute install-linux.sh as the superuser, do what it asks for.

$ tar -jxvf zyn-fusion-linux-64bit-3.0.3-patch1-release.tar.bz2
$ cd zyn-fusion
$ sudo bash ./install-linux.sh

Using Zyn-Fusion

You can use Zyn-Fusion in a LV2-capable host, a VST-capable host or run a standalone version via:

$ zynaddsubfx

NOTE: If you don't use JACK and use ALSA, you can run the software with zynaddsubfx -O alsa. Details in the help message: zynaddsubfx -h.

Clone this wiki locally
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.