Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fast preset loading in pianoteq does not cover user presets #129

Open
hal80 opened this issue Feb 9, 2020 · 0 comments
Open

Fast preset loading in pianoteq does not cover user presets #129

hal80 opened this issue Feb 9, 2020 · 0 comments

Comments

@hal80
Copy link

@hal80 hal80 commented Feb 9, 2020

Describe the bug
There is a bug in loading or changing into pianoteq user presets.
This affects at least pianoteq stage 6.6 version in the most recent (february 4, 2020) zynthian.
User presets can only be properly loaded when they are the first preset to be loaded in pianoteq.
If there was any other of the standard presets loaded before, the custom preset is not loaded correctly: there appears the name of the user preset in the display, but the sound is still from the previously loaded standard preset.
Exception: load standard preset from the last instrument and after that, a user preset. Thus, the he “distance” from presets being loaded is big enough (aka > 127) and user presets load correctly.

To Reproduce
Steps to reproduce the behavior:
0. Create user preset for e.g. Steinway D in native pianoteq gui.

  1. Zynthian: Remove all layers
  2. Create new pianoteq layer
  3. Select standard (non user) preset (e.g. Steinway D) --> loads correctly
  4. Select user preset within the same instrument (Steinway D) --> does not load correctly (only name appears, but sound is still from from previous preset).

Expected behavior
Step 4 - both displayed name and sound should be from custom preset.

Setup:

See discussion here:

https://discourse.zynthian.org/t/bug-in-loading-changing-pianoteq-presets/3772

Related:
Fast preset loading:

https://discourse.zynthian.org/t/new-features-improved-audio-routing-pianoteq-fast-preset-loading/2326

@jofemodo jofemodo added this to New in Zynthian Tracker Feb 9, 2020
@jofemodo jofemodo moved this from New to Analyzing in Zynthian Tracker Feb 17, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Zynthian Tracker
  
Analyzing
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.