Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Broken for current RubyPython #8

rbq opened this Issue Nov 19, 2012 · 3 comments


None yet
2 participants

rbq commented Nov 19, 2012

Glorify currently only works with gem 'rubypython', '< 0.5.0' added. Maybe the RubyPython.configure stuff should just be removed?


zzak commented Nov 19, 2012

Perhaps we need to depend on a specific version of pygments.rb that satisfies the rubypython dependency?

I haven't checked, any reason to upgrade?

The RubyPython.configure stuff was there historically for heroku support I believe.

@rbq It's great that you're using glorify, I'm curious to see your usecase!

rbq commented Nov 19, 2012

RubyPython#configure has been removed in 0.6, but the README mentions RubyPython.start(:python_exe => "python2.7").

Anyway, pygments.rb doesn't seem to have rubypython as a dependency anymore, it's posix-spawn now. So I guess glorify is currently configuring something that isn't used at all.

I think the best solution would be a glorify 2.1 that pins pygments.rb to ~> 0.2.0, followed by a glorify 0.3.0 that doesn't rely on RubyPython. Heroku user should probably use a buildpack that ensures they have a proper Python setup.

My use-case isn't really exciting. I'm using Ruby to teach basics about web dev in a seminar and will have the students turn in documentation/tutorials about various topics (Ruby/Agile/VCS related) instead of term papers (in Markdown, obviously). Currently I'm writing a little Sinatra app for this.


zzak commented Nov 19, 2012

Thank you for looking into this, I think your solution is good.

@rbq That sounds like a very good use-case, knowledge is power! 😉

@zzak zzak closed this in 7bc91a8 Dec 4, 2012

zzak added a commit that referenced this issue Dec 4, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment