Permalink
Newer
Older
100644 57 lines (48 sloc) 1.64 KB
1
# Why use bundler?
Feb 26, 2011
2
# Well, not all development dependencies install on all rubies. Moreover, `gem
3
# install sinatra --development` doesn't work, as it will also try to install
4
# development dependencies of our dependencies, and those are not conflict free.
5
# So, here we are, `bundle install`.
6
#
7
# If you have issues with a gem: `bundle install --without-coffee-script`.
8
9
RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
10
TILT_REPO = "git://github.com/rtomayko/tilt.git"
11
12
source :rubygems unless ENV['QUICK']
13
gemspec
14
15
gem 'rake'
16
gem 'rack-test', '>= 0.5.6'
17
18
# Allows stuff like `tilt=1.2.2 bundle install` or `tilt=master ...`.
19
# Used by the CI.
20
tilt = (ENV['tilt'] || 'stable').dup
21
tilt.sub! 'tilt-', ''
22
if tilt != 'stable'
23
tilt = {:git => TILT_REPO, :branch => tilt} unless tilt =~ /(\d+\.)+\d+/
24
gem 'tilt', tilt
25
end
26
27
gem 'haml', '>= 3.0', :group => 'haml'
28
gem 'builder', :group => 'builder'
29
gem 'erubis', :group => 'erubis'
30
gem 'less', :group => 'less'
31
gem 'liquid', :group => 'liquid'
32
gem 'nokogiri', :group => 'nokogiri'
33
gem 'slim', :group => 'slim'
34
gem 'RedCloth', :group => 'redcloth'
Feb 26, 2011
35
gem 'coffee-script', '>= 2.0', :group => 'coffee-script'
36
gem 'rdoc', :group => 'rdoc'
37
gem 'kramdown', :group => 'kramdown'
38
gem 'maruku', :group => 'maruku'
39
gem 'creole', :group => 'creole'
40
41
platforms :ruby do
42
gem 'rdiscount', :group => 'rdiscount'
43
gem 'bluecloth', :group => 'bluecloth'
44
end
45
46
platforms :ruby_18, :jruby do
47
gem 'json', :group => 'coffee-script'
48
gem 'markaby', :group => 'markaby'
49
gem 'radius', :group => 'radius'
50
end
51
52
platforms :mri_18 do
53
# bundler platforms are broken
54
next if RUBY_ENGINE != 'ruby' or RUBY_VERSION > "1.8"
55
gem 'rcov', :group => 'rcov'
56
end