New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

syntax error #7

Closed
Vesa49 opened this Issue Mar 1, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@Vesa49

Vesa49 commented Mar 1, 2018

I run WP 4.9.4–fi and cannot activate plugin.
Is there way to fix it without coding skills?
"Parse error: syntax error, unexpected T_STRING in .......external-media-without-import.php on line 25"
Thanks Vesa

@zzxiang

This comment has been minimized.

Owner

zzxiang commented Mar 2, 2018

Seems it has something to do with localization. That's strange because I also use WP 4.9.4. But I don't know what's the difference between 4.9.4 and 4.9.4-fi. I'll first find out where's T_STRING defined. Also, what's your PHP version?

@Vesa49

This comment has been minimized.

Vesa49 commented Mar 2, 2018

@zzxiang

This comment has been minimized.

Owner

zzxiang commented Mar 4, 2018

I did some investigation just now. Line 25 of external-media-without-import.php is just a namespace declaration. The parse error usually occurs on PHP version < 5.3 (see PHP 5.3.0 Release Announcement). If you are using PHP version 5.6.30 it should be fine. Is it possible that there're multiple PHP versions installed on your server and your WordPress is using a version older than 5.3.0?

@Vesa49

This comment has been minimized.

Vesa49 commented Mar 5, 2018

@zzxiang zzxiang closed this Mar 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment