-
Notifications
You must be signed in to change notification settings - Fork 1
/
Copy pathDesigner PDF Viewer.java
101 lines (70 loc) · 2.88 KB
/
Designer PDF Viewer.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
/*When you select a contiguous block of text in a PDF viewer, the selection is highlighted with a blue rectangle. In this PDF viewer, each word is highlighted independently. For example:
PDF-highighting.png
In this challenge, you will be given a list of letter heights in the alphabet and a string. Using the letter heights given, determine the area of the rectangle highlight in assuming all letters are wide.
For example, the highlighted . Assume the heights of the letters are and . The tallest letter is high and there are letters. The hightlighted area will be so the answer is .
Function Description
Complete the designerPdfViewer function in the editor below. It should return an integer representing the size of the highlighted area.
designerPdfViewer has the following parameter(s):
h: an array of integers representing the heights of each letter
word: a string
Input Format
The first line contains space-separated integers describing the respective heights of each consecutive lowercase English letter, ascii[a-z].
The second line contains a single word, consisting of lowercase English alphabetic letters.
Constraints
, where is an English lowercase letter.
contains no more than letters.
Output Format
Print a single integer denoting the area in of highlighted rectangle when the given word is selected. Do not print units of measure.
Sample Input 0
1 3 1 3 1 4 1 3 2 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5
abc
Sample Output 0
9
Explanation 0
We are highlighting the word abc:
Letter heights are , and . The tallest letter, b, is high. The selection area for this word is .
Note: Recall that the width of each character is .
Sample Input 1
1 3 1 3 1 4 1 3 2 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 7
zaba
Sample Output 1
28
Explanation 1
The tallest letter in is at . The selection area for this word is .
*/
import java.util.*;
public class DO {
public static void main(String args[])
{Scanner sc=new Scanner(System.in);
//inputing the string
int arr[]=new int[26]; //aray for height of each alphabet
int count=0;
int brr[]=new int[10];
char[] alpha= {'a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z'}; //array containg alphabets from a-z
for(int i=0;i<26;i++)
{
arr[i]=sc.nextInt(); //inputing length of each alphabet
}
String s=sc.next();
for(int i=0;i<s.length();i++)
{
for(int j=0;j<26;j++)
{
if(s.charAt(i)==alpha[j])
{
brr[count]=arr[j];
count++;
}
}
}
int big=0;
for(int i=0;i<count;i++)
{
if(brr[i]>big)
{
big=brr[i];
}
}
System.out.println(big*(s.length()));
}
}