-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathswapSDA.java
44 lines (31 loc) · 899 Bytes
/
swapSDA.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
package Arrays;
import java.util.Scanner;
// WAP IN JAVA TO ENTER 10 NUMBERS INTO SDA AND THEN SWAP FIRST HALF OF THE ARRAY WITH LAST HALF
/*
// index no. 0 1 2 3 4 5 6 7 8 9
SAMPLE INPUT: 1 2 3 4 5 6 7 8 9 10
SAMPLE OUTPUT: 10 9 8 7 6 5 4 3 2 1
*/
public class swapSDA {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int arr[] = new int[10];
System.out.println("Enter 10 numbers: ");
for (int i = 0; i < 10; i++)
arr[i] = sc.nextInt();
int ptr1=0,ptr2=5,temp;
while (ptr2 < 10) {
temp = arr[ptr1];
arr[ptr1] = arr[ptr2];
arr[ptr2] = temp;
++ptr1;
++ptr2;
}
System.out.println("Swapped array : ");
for (int i = 0; i < 10; i++)
System.out.print(arr[i] + " ");
sc.close();
}
public static void swap (){
}
}