New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Blocking Mode on interfaces does not work #3081

Closed
nrllewellyn opened this Issue Sep 10, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@nrllewellyn

nrllewellyn commented Sep 10, 2017

Description

Expected behavior: Interface detects presence of items in inventory and blocks, if "blocking mode" enabled.

Actual behavior: Interface acts as if there was ALWAYS an item in the target inventory.

Example setup:
2017-09-10_16 34 01
The interface on the right contains the pattern "export stone, get button". The chest is empty, and the crafting blocks forever.

Tested with the following "target inventories":

  • Chest
  • Trapped chest
  • Dropper
  • Dispenser
  • Furnace
  • Shulker box

The only mod installed was AE2 (and Forge, obviously)

Environment

Tested in single player, but similar (less exhaustive) tests were also performed on a multiplayer server with more mods. (Same results.)

  • Minecraft Version: 1.12.1
  • AE2 Version: rv5-alpha-4
  • Forge Version: 14.22.0.2475

yueh added a commit that referenced this issue Sep 10, 2017

@yueh yueh added the type-bug label Sep 10, 2017

@yueh yueh closed this in 771a944 Sep 11, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment