Permalink
Browse files

Remove JSON classes now that we don't need to support php < 5.2. Use …

…the native functions instead.
  • Loading branch information...
1 parent 01a2bbe commit cc3c3aeceff85c44803129c5eaa70b766f98d10a @ex-nerd ex-nerd committed Dec 30, 2010
View
@@ -1,27 +0,0 @@
-<?php
-/**
- * Wrapper so we can support php less then 5.2 and/or installs without native json built in.
- * The native json is much faster, so prefer it if we can.
- *
- * @license GPL
- *
- * @package MythWeb
- * @subpackage TV
- *
-/**/
-
-class JSON {
- public static function encode($data) {
- if (function_exists('json_encode'))
- return json_encode($data);
- $JSON = new Services_JSON();
- return $JSON->encode($data);
- }
-
- public static function decode($data) {
- if (function_exists('json_decode'))
- return json_decode($data);
- $JSON = new Services_JSON();
- return $JSON->decode($data);
- }
-}
Oops, something went wrong.

0 comments on commit cc3c3ae

Please sign in to comment.