Permalink
Browse files

fix(package.json): remove es6-promise from the peerDependency list

As of zone.js@0.6* we no longer require an es6-promise polyfill. The polyfill is only needed on browsers that don't
have native Promise support.
  • Loading branch information...
IgorMinar committed Mar 19, 2016
1 parent 5c330ea commit 8b67b07580b339a1718dba8e1ee15f1eb1501477
Showing with 2 additions and 12 deletions.
  1. +0 −1 modules/angular2/package.json
  2. +0 −1 modules/benchpress/package.json
  3. +0 −3 npm-shrinkwrap.clean.json
  4. +2 −6 npm-shrinkwrap.json
  5. +0 −1 package.json
@@ -9,7 +9,6 @@
"repository": <%= JSON.stringify(packageJson.repository) %>,
"devDependencies": <%= JSON.stringify(packageJson.defaultDevDependencies) %>,
"peerDependencies": {
"es6-promise": "<%= packageJson.dependencies['es6-promise'] %>",
"es6-shim": "<%= packageJson.dependencies['es6-shim'] %>",
"reflect-metadata": "<%= packageJson.dependencies['reflect-metadata'] %>",
"rxjs": "<%= packageJson.dependencies['rxjs'] %>",
@@ -10,7 +10,6 @@
"repository": <%= JSON.stringify(packageJson.repository) %>,
"dependencies": {
"angular2": "<%= packageJson.version %>",
"es6-promise": "<%= packageJson.dependencies['es6-promise'] %>",
"es6-shim": "<%= packageJson.dependencies['es6-shim'] %>",
"reflect-metadata": "<%= packageJson.dependencies['reflect-metadata'] %>",
"rxjs": "<%= packageJson.dependencies['rxjs'] %>",
@@ -2083,9 +2083,6 @@
"es6-module-loader": {
"version": "0.17.9"
},
"es6-promise": {
"version": "3.0.2"
},
"es6-shim": {
"version": "0.35.0"
},

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
@@ -32,7 +32,6 @@
"test": "gulp test.all.js && gulp test.all.dart"
},
"dependencies": {
"es6-promise": "^3.0.2",
"es6-shim": "^0.35.0",
"reflect-metadata": "0.1.2",
"rxjs": "5.0.0-beta.2",

0 comments on commit 8b67b07

Please sign in to comment.