Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

I cannot migrate db.Is this windows os issue!! #21

Closed
pradeepbicc opened this Issue · 2 comments

2 participants

@pradeepbicc

rake community_engine:install:migrations
I run this command and was ok all migration files got copied giving me warning

WARNING: SimpleCov is activated, but you're not running Ruby 1.9+ - no coverage analysis will happen
WARNING: Global access to Rake DSL methods is deprecated. Please include
... Rake::DSL into classes and modules which use the Rake DSL methods.
WARNING: DSL method Eventify::Application#task called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/application.rb:187:in `initialize_tasks'
WARNING: Global access to Rake DSL methods is deprecated. Please include
... Rake::DSL into classes and modules which use the Rake DSL methods.
WARNING: DSL method CommunityEngine::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:550
WARNING: DSL method CommunityEngine::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:551
WARNING: DSL method CommunityEngine::Engine#desc called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:552
WARNING: DSL method CommunityEngine::Engine#task called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:553
WARNING: Global access to Rake DSL methods is deprecated. Please include
... Rake::DSL into classes and modules which use the Rake DSL methods.
WARNING: DSL method Kaminari::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:550
WARNING: DSL method Kaminari::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:551
WARNING: DSL method Kaminari::Engine#desc called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:552
WARNING: DSL method Kaminari::Engine#task called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:553
WARNING: Global access to Rake DSL methods is deprecated. Please include
... Rake::DSL into classes and modules which use the Rake DSL methods.
WARNING: DSL method PrototypeRails::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:550
WARNING: DSL method PrototypeRails::Engine#namespace called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:551
WARNING: DSL method PrototypeRails::Engine#desc called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:552
WARNING: DSL method PrototypeRails::Engine#task called at C:/RailsInstaller/Ruby1.8.7/lib/ruby/gems/1.8/gems/railties-3.1.0.beta1/lib/rails/engine.rb:553

And I ran this command : rake db:migrate : and rake aborted!!

undefined method `debug_rjs=' for ActionView::Base:Class

Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)
I'm on windows!!

@pradeepbicc

i removed
#config.action_view.debug_rjs = true from configuration/environment/development.rb
and everything went fine!!

@steveroot

Thanks for posting the solution pradeepbicc

For others, I'm moving an app between rails 2 to rails 3, so perhaps that's the cause.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.