Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 29 lines (23 sloc) 1.34 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
require "best_in_place/version"

Gem::Specification.new do |s|
  s.name = "best_in_place"
  s.version = BestInPlace::VERSION
  s.platform = Gem::Platform::RUBY
  s.authors = ["Bernat Farrero"]
  s.email = ["bernat@itnig.net"]
  s.homepage = "http://github.com/bernat/best_in_place"
  s.summary = %q{It makes any field in place editable by clicking on it, it works for inputs, textareas, select dropdowns and checkboxes}
  s.description = %q{BestInPlace is a jQuery script and a Rails 3 helper that provide the method best_in_place to display any object field easily editable for the user by just clicking on it. It supports input data, text data, boolean data and custom dropdown data. It works with RESTful controllers.}

  s.rubyforge_project = "best_in_place"

  s.files = `git ls-files`.split("\n")
  s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
  s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.require_paths = ["lib"]

  s.add_dependency "rails", "~> 3.1"
  s.add_dependency "jquery-rails"

  s.add_development_dependency "rspec-rails", "~> 2.8.0"
  s.add_development_dependency "nokogiri", ">= 1.5.0"
  s.add_development_dependency "capybara", ">= 1.0.1"
end
Something went wrong with that request. Please try again.