Skip to content


Subversion checkout URL

You can clone with
Download ZIP


cucumber_loader does not work if json 1.7.6 is installed #85

MMore opened this Issue · 1 comment

1 participant



We are using ci_reporter with jenkins. Another tasks installed in addition to json 1.7.5 1.7.6. Now these two versions are installed.

This command should execute the command with the fixed json version, which is 1.7.5.
bundle exec ruby -r GEM_PATH/lib/ci/reporter/rake/cucumber_loader -S cucumber --format CI::Reporter::Cucumber

But nevertheless I got the following error:

/usr/local/rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.2/lib/bundler/runtime.rb:31:in `block in setup': You have already activated json 1.7.6, but your Gemfile requires json 1.7.5. Using bundle exec may solve this. (Gem::LoadError)    from /usr/local/rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.2/lib/bundler/runtime.rb:17:in `setup'
from /usr/local/rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.2/lib/bundler.rb:116:in `setup'
from /usr/local/rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.2/lib/bundler/setup.rb:7:in `<top (required)>'
from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'

Any idea?

@MMore MMore closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.