Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP


Weird resolution when the same package appears in require and require-dev #2056

stof opened this Issue · 0 comments

1 participant


Behat Symfony2Extension has symfony/symfony: ~2.1 as a dev requirement. On Travis, it requires it with a more strict requirement (to test against different versions).
This was working properly 24 days ago (for the previous Travis build) but it is failing today with a weird output: it installed 2.3.1 and then tried to find 2.2.*.

See for the output.

The latest composer is used as it runs self-update at the beginning of the build.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.