Change the gemspec/Gemfile line from:
gem 'devise', '~> 1.5.0'
gem 'devise', '>= 1.5.0'
Devise 2 should mantain retro-compatiblity so I don't think there are too many problems (from the devise homepage => "be sure that your application is fine running on Devise 1.5.x and that you are running on at least Rails 3.1")
Type in gemspec. Closes #71