Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to install the child theme? #1

Closed
grayspace opened this issue Sep 30, 2015 · 4 comments

Comments

Projects
None yet
2 participants
@grayspace
Copy link

commented Sep 30, 2015

Hi, great work on porting this theme over to WordPress! I got the main Clean Blog theme installed, but when I tried to install this child theme, it says it is broken. Any ideas? I used the theme uploader feature in the admin. Thanks!

@robertdevore

This comment has been minimized.

Copy link
Member

commented Sep 30, 2015

Can you let me know what the error message says?

I've installed it through the theme uploader feature on two separate installs and it worked both times for me.

@grayspace

This comment has been minimized.

Copy link
Author

commented Oct 1, 2015

After uploading...

This theme requires a parent theme. Checking if it is installed…

The parent theme could not be found. You will need to install the parent theme, cleanblog, before you >can use this child theme.

Theme installed successfully.

And on the installed themes page...

Broken Themes

The following themes are installed but incomplete. Themes must have a stylesheet and a template.

Clean Blog Child - The parent theme is missing. Please install the "cleanblog" parent theme.

But, I already installed the cleanbog theme, and I tried installing the child with the parent active as well as with another theme active. Still no go.

@robertdevore

This comment has been minimized.

Copy link
Member

commented Oct 1, 2015

It may be an issue with the way github has cleanblog-master as the folder name, instead of cleanblog which is what the child theme checks for.

Are you able to get check the folder name for the cleanblog-master folder, and change it to cleanblog through your host?

That should fix the issue

@robertdevore

This comment has been minimized.

Copy link
Member

commented Oct 3, 2015

I'm going to go ahead and close this issue for now. If the issue still persists, let me know and I can look into it again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.