Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not installable with vagrant plugin install on Ubuntu 18.04 beta 1 #256

Closed
russianlagman opened this issue Apr 3, 2018 · 12 comments
Closed

Not installable with vagrant plugin install on Ubuntu 18.04 beta 1 #256

russianlagman opened this issue Apr 3, 2018 · 12 comments

Comments

@russianlagman
Copy link

@russianlagman russianlagman commented Apr 3, 2018

bigboss@bigboss:~/Work/project$ vagrant plugin install vagrant-hostmanager
Installing the 'vagrant-hostmanager' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0)
  Activated fog-core-1.45.0
  which does not match conflicting dependency (~> 1.43.0)

  Conflicting dependency chains:
    fog-core (= 1.45.0), 1.45.0 activated

  versus:
    vagrant-libvirt (> 0), 0.0.41 activated, depends on
    fog-core (~> 1.43.0)

bigboss@bigboss:~/Work/affstats$ vagrant -v
Vagrant 2.0.2
@purencool

This comment has been minimized.

Copy link

@purencool purencool commented Apr 8, 2018

I can confirm this issue

@ghost

This comment has been minimized.

Copy link

@ghost ghost commented Apr 9, 2018

+1

@manishmahabir

This comment has been minimized.

Copy link

@manishmahabir manishmahabir commented Apr 17, 2018

vagrant ssh
The following plugins will be installed: vagrant-auto_network, vagrant-vbguest, vagrant-hostsupdater Installing the 'vagrant-auto_network' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (> 1.43.0) and fog-core (= 1.45.0)
Activated fog-core-1.45.0
which does not match conflicting dependency (
> 1.43.0)

Conflicting dependency chains:
fog-core (= 1.45.0), 1.45.0 activated

versus:
vagrant-libvirt (> 0), 0.0.41 activated, depends on
fog-core (~> 1.43.0)

Installing the 'vagrant-vbguest' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (> 1.43.0) and fog-core (= 1.45.0)
Activated fog-core-1.45.0
which does not match conflicting dependency (
> 1.43.0)

Conflicting dependency chains:
fog-core (= 1.45.0), 1.45.0 activated

versus:
vagrant-libvirt (> 0), 0.0.41 activated, depends on
fog-core (~> 1.43.0)

Installing the 'vagrant-hostsupdater' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (> 1.43.0) and fog-core (= 1.45.0)
Activated fog-core-1.45.0
which does not match conflicting dependency (
> 1.43.0)

Conflicting dependency chains:
fog-core (= 1.45.0), 1.45.0 activated

versus:
vagrant-libvirt (> 0), 0.0.41 activated, depends on
fog-core (~> 1.43.0)

Please run again

@russianlagman

This comment has been minimized.

Copy link
Author

@russianlagman russianlagman commented Apr 17, 2018

Issue is simple, vagrant-libvirt installed with vagrant on 18.04 has version 1.45.0. Version 1.43.0 is not available for this distro.

@amartyniuk

This comment has been minimized.

Copy link

@amartyniuk amartyniuk commented Apr 27, 2018

So what's the fix?

@quangthe

This comment has been minimized.

Copy link

@quangthe quangthe commented Apr 28, 2018

Have same issue when install vagrant-aws. My PC running Ubuntu 18.04.

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0)
  Activated fog-core-1.45.0
  which does not match conflicting dependency (~> 1.43.0)

  Conflicting dependency chains:
    fog-core (= 1.45.0), 1.45.0 activated

  versus:
    vagrant-libvirt (> 0), 0.0.41 activated, depends on
    fog-core (~> 1.43.0)
@Potherca

This comment has been minimized.

Copy link

@Potherca Potherca commented May 3, 2018

I had a similar problem that was resolved when I updated to Vagrant v2.0.3 :

wget -c https://releases.hashicorp.com/vagrant/2.0.3/vagrant_2.0.3_x86_64.deb
sudo dpkg -i vagrant_2.0.3_x86_64.deb

(I have not yet tried with v2.0.4)

@quangthe

This comment has been minimized.

Copy link

@quangthe quangthe commented May 3, 2018

@Potherca Thanks! It works for me as well.

@lucasifto

This comment has been minimized.

Copy link

@lucasifto lucasifto commented May 3, 2018

@Potherca works for me too...tanks

@Potherca

This comment has been minimized.

Copy link

@Potherca Potherca commented May 3, 2018

Although I appreciate the "Thanks", I would like to suggest simply adding a 👍 to my comment.

@macduff23

This comment has been minimized.

Copy link

@macduff23 macduff23 commented Feb 4, 2020

Is there a fix other than reverting to an older vagrant package?

Conflict present With vagrant 2.2.3 on ubuntu 19'ish - uname -a
Linux 5.3.0-29-generic , "Ubuntu"v="19.10 (Eoan Ermine)"

Err ~ Installing the 'vagrant-lxd' plugin. This can take a few minutes..
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:
conflicting dependencies fog-core (> 1.43.0) and fog-core (= 2.1.0)
Activated fog-core-2.1.0
which does not match conflicting dependency (
> 1.43.0)
Conflicting dependency chains:
fog-core (= 2.1.0), 2.1.0 activated
versus:
vagrant-libvirt (> 0), 0.0.41 activated, depends on
fog-core (~> 1.43.0)
root@xxxx:/home/vagrant# vagrant -v
Vagrant 2.2.3

Fix - apt-get remove vagrant

  • apt-get update

Then revert to older vagrant deb version - (as suggested above:)

Alls good:)
Installed the plugin 'vagrant-lxd (0.4.4)'!
root@xxx:/home/vagrant# vagrant -v
Vagrant 2.0.3

@russianlagman

This comment has been minimized.

Copy link
Author

@russianlagman russianlagman commented Feb 4, 2020

Got the same issue on 19.10 ubuntu.
The only solution is to get latest .deb package from the vagrant official site and to install it manualy.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
9 participants
You can’t perform that action at this time.