New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

problem with comma in a single argument alias (Origin: bugzilla #667844) #4527

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component general for ---
Reported in version 1.7.3 on platform Other
Assigned to: Dimitri van Heesch

On 2012-01-13 07:23:02 +0000, Roma wrote:

Alias definition:
ALIASES += WIP{1}="

\1
"

Alias usage:
\WIP{Die not, spare life}

Result:
{Die not, spare life} //no frame! only the brackets left from the command

In case if comma is escaped, alias works fine:
\WIP{Die not, spare life}
results in:
Die not, spare life //text in a frame - as expected

But I don't want to escape commas every time, and according to Doxygen documentation "13.2 Aliases with arguments" it is only required for aliases with more than one argument.

On 2012-02-12 13:20:52 +0000, Dimitri van Heesch wrote:

The documentation does indeed not say anything specific about the need for escaping commas for commands with a single argument.

I'll implement your suggestion in the next subversion update.

On 2012-02-25 15:37:33 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.0. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment