Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Mount and install the operating system to a temporary image #120

Closed
pierreganty opened this issue May 13, 2016 · 3 comments

Comments

@pierreganty
Copy link

commented May 13, 2016

Trying to upgrade form 10.9.5 to ElCapitan 10.11.4 following the steps as described.
I tried with 64g instead of 32g when creating /tmp/output.sparseimage but the error remains.

sudo installer -pkg /tmp/installesd/Packages/OSInstall.mpkg -tgt /tmp/os
Password:
installer: Package name is OS X
installer: Installing at base path /private/tmp/os
2016-05-13 11:50:09.776 installer[13369:8977] Looking for system packages
2016-05-13 11:50:09.780 installer[13369:8977] no system packages found
2016-05-13 11:50:09.781 installer[13369:8977] No or Invalid system receipts found on /private/tmp/os/Recovered Items
2016-05-13 11:50:09.781 installer[13369:8977] Attempting fallback using: /System/Library/PrivateFrameworks/SystemMigration.framework/Resources/FallbackSystemFiles.plist
2016-05-13 11:50:09.910 installer[13369:8977] Finding system files...
2016-05-13 11:50:11.486 installer[13369:8977] Writing system path cache.
2016-05-13 11:50:11.501 installer[13369:8977] FSF cache NOT written: /private/tmp/os/Recovered Items/System/Library/Caches/com.apple.FindSystemFiles.plist
installer: The install failed (There is not enough space on this disk to install the selected items.  Deselect at least 10.86 GB and try again.)```
@pierreganty

This comment has been minimized.

Copy link
Author

commented May 13, 2016

Using AutoDMG I found:

  1. Can I build images for one OS while running another?

No. Apple's installer does not work across OS versions. If you want to build a 10.9 image, AutoDMG needs to run on a 10.9 machine.

provided it applies here too, it needs to be written somewhere.

@drduh drduh closed this in 89b03d8 May 18, 2016
@rawtaz

This comment has been minimized.

Copy link

commented Dec 20, 2016

This is quite odd. I have many times used createinstallmedia to build installer USB drives for newer versions than the one I'm running the command on, and it's never been a problem. I've gone from various versions to newer ones, sometimes one step up and sometimes two (e.g. 10.9 to 10.10 or 10.9 to 10.11).

@pzuraq

This comment has been minimized.

Copy link

commented Mar 26, 2017

I was able to run createinstallmedia on an El Capitan machine for macOS Sierra. Maybe this only applies to creating full images using AutoDMG?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.