after upgrade, Failed to load module : Module did not self-register #3108

Open
flotho opened this Issue Dec 29, 2016 · 1 comment

Projects

None yet

2 participants

@flotho
flotho commented Dec 29, 2016

Hi,

I'm trying to run the latest develop branch of etherpad. I was previously running with the 1.5 release and already had some modules. Once the update is, the etherpad starts and I have the following message :

Failed to load '/opt/etherpad/etherpad-lite/node_modules/ep_ldapauth/ep_ldapauth' for 'ep_ldapauth/ep_ldapauth/hooks/authenticate': Error: Module did not self-register.
[2016-12-29 13:30:20.283] [ERROR] console - Failed to load '/opt/etherpad/etherpad-lite/node_modules/ep_ldapauth/ep_ldapauth' for 'ep_ldapauth/ep_ldapauth/hooks/authorize': Error: Module did not self-register.
[2016-12-29 13:30:20.284] [ERROR] console - Failed to load '/opt/etherpad/etherpad-lite/node_modules/ep_ldapauth/ep_ldapauth' for 'ep_ldapauth/ep_ldapauth/hooks/handleMessage': Error: Module did not self-register.

What could be the problem?
Is it necessarily a plugin issue ?

Any help would be appreciated

@lpagliari
Contributor

Does this help?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment