Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Packages jquery.sparklines library as a Gem for Ruby on Rails
Ruby JavaScript
branch: master

This branch is 3 commits ahead of RobAtHedtek:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
test
vendor/assets/javascripts
.gitignore
Gemfile
LICENSE
README.md
Rakefile
jquery-sparkline-rails.gemspec

README.md

jquery-sparkline-rails

Sparklines are small but intense charts. jquery.sparklines generates a range of cool sparklines using JavaScript.

This project packages jquery.sparkline - a great little sparkline library - as a Gem for Ruby on Rails. Great for keeping your pipe clean and tidy

License: New BSD License (just like jquery.sparkline)

Rails: 3.2 and up

jquery-sparkline-rails 2.0 includes jquery.sparkline 2.0

Installation

Add this line to your application's Gemfile:

gem 'jquery-sparkline-rails', git: "https://github.com/RobAtHedtek/jquery-sparkline-rails.git"

And then execute:

$ bundle

Or install it yourself as:

$ gem install jquery-sparkline-rails

Usage

Just add a require 'sparklines' towards the top of your source in the usual fashion.

For Coffeescript

#= require 'sparklines'

For JavaScript

//= require 'sparklines'

Contributing

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Added some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request
Something went wrong with that request. Please try again.