Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Kein onboard WLAN mit ASUS Tinkerboard #380

Closed
RonVogt opened this Issue Jul 24, 2018 · 12 comments

Comments

Projects
None yet
5 participants
@RonVogt
Copy link

commented Jul 24, 2018

RaspiMatic 2.35.16.20180715 läuft auf meinem Tinker Board S aktuell nur mit Ethernet. Die Anleitung zur Aktivierung von WLAN funktioniert beim Tinkerboard S nicht. Verwendet wird das Funkmodul RPI-RF-MOD. Gibt es bereits eine Möglichkeit WLAN für das Tinkerboard S mit dem RPI-RF-MOD zu aktivieren?

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Jul 28, 2018

In den Testsystemen hier funktioniert das WLAN prinzipiell problemlos. Folgende Kommandosequenz zeigt alle verfügbaren WLANs in der Umgebung z.B. an:

rfkill unblock 0
iw wlan0 scan

Nach dem letzten Befehl sollte dann eine Ausgabe aller gefundenen WLANs ausgegeben werden.

@RonVogt

This comment has been minimized.

Copy link
Author

commented Jul 28, 2018

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Jul 28, 2018

Alles klar, dann muss ich das noch bei Gelegenheit testen.

@RonVogt

This comment has been minimized.

Copy link
Author

commented Jul 28, 2018

@RonVogt RonVogt closed this Jul 28, 2018

@jens-maus jens-maus reopened this Jul 28, 2018

@RonVogt

This comment has been minimized.

Copy link
Author

commented Sep 2, 2018

Seit dem letzten Update werden die WLAN nach einem Scan nicht mehr angezeigt.

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Sep 2, 2018

@RonVogt Was wird denn an einem HDMI Monitor angezeigt sobald man beim booten auf einer Tastatur ALT+F2 drückt um Statusmeldungen auszugeben?!?

@ramazotti7

This comment has been minimized.

Copy link

commented Dec 29, 2018

Hallo Herr Maus,
ich habe heute mein neues Tinker Board S in Betrieb genommen, mit LAN auch kein Problem. Leider mit WLAN. Recherchen haben mich auf diese Seite gebracht, leider finde ich hier keine Hilfe zur Lösung meines Problems.
Folgende vorgehensweise hat bei meinem pi 3b+ funktioniert, beim tinker board leider nicht:

rfkill unblock wifi
iw wlan0 scan --> zeigt die Netzwerke an
--> in der Ausgabe nach der SSID suchen (xxx)
//Dann folgende Datei kopieren:
cp /etc/config_templates/wpa_supplicant.conf /etc/config/
wpa_passphrase "xxx" "abcabcyxxx" >>/etc/config/wpa_supplicant.conf
und Neustart ohne Lan-Kabel.
Gibt es hier tatsächlich Probleme oder mache ich etwas falsch?
Vielen Dank im Voraus für Ihre Mühe.
Rainer

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Dec 29, 2018

Diese Symptome habe ich auch bereits festgestellt. Leider habe ich dafür jedoch noch keine Lösung/Grund gefunden warum man trotz gefundener SSIDs die WLAN Verbindung mit dem onboard-WLAN eines Tinkerboard nicht aufgebaut werden kann. Schaue ich mir bei Gelegenheit einmal näher an. Jedoch sei ohnehin noch einem darauf hingewiesen das ein aktiviertes WLAN auf dem Tinkerboard oder RaspberryPi auf dem auch das HM-MOD-RPI-PCB bzw RPI-RF-MOD am GPIO betrieben wird keine gute Idee ist da ws zu Störungen des HomeMatic Funkverkehres kommen kann. Daher hat das für mich niedrige Priorität.

Auch würde ich dazu raten besser einen externen WLAN USB Stick zu verwenden der mit langem USB Kabel abgesetzt wird. Dieser sollte problemlos am Tinkerboard funktionieren.

@jens-maus jens-maus changed the title Kein WLAN mit Tinkerboard S Kein onboard WLAN mit ASUS Tinkerboard Dec 29, 2018

@jens-maus jens-maus added this to the future release milestone Dec 29, 2018

@libertyx82

This comment has been minimized.

Copy link
Contributor

commented Dec 29, 2018

Wäre bei einem Thinkerboard S eine abgesetzte Antenne für's WLAN nicht ausreichend?
Ein i-PEX Anschluss ist ja beim S vorhanden.

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Dec 29, 2018

Das könntest du probieren. Es kann auch gut sein das das onvoard WLAN eonfach nur nicht geht weil mit dem Funkmodul auf dem GPIO keine Verbindung zustande kommt. Also winfach probieren. Auf der anderen Seite sollte das mit einem USB WLAN Stick ja auch kein Problem sein...

@angler180

This comment has been minimized.

Copy link

commented Feb 2, 2019

Auch ich habe dieses Problem mit der fehlenden Wlan Verbindung.
Ich habe an den i-PEX Anschluss eine externe Antenne mit einem Kabel angeschlossen und direkt neben die Fritzbox gestellt.
Der SSID wird mit super Signalstärke gefunden, lässt sich aber nicht Verbinden.

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Feb 2, 2019

Gut, dann können wir zumindest ausschliessen das das WLAN wegen der internen Antenne nur nicht geht. Vmtl. ist das alles irgendetwas kernel/software seitig und müsste mal debuggt werden.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.