Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Symfony Http Message Bridge Dropped Support for Diactoros #31017

Closed
ivannovak opened this issue Jan 3, 2020 · 3 comments · Fixed by #31018
Closed

Symfony Http Message Bridge Dropped Support for Diactoros #31017

ivannovak opened this issue Jan 3, 2020 · 3 comments · Fixed by #31018

Comments

@ivannovak
Copy link

@ivannovak ivannovak commented Jan 3, 2020

  • Laravel Version: 5.1 through current 6.*

Description:

Top level indication:

Symfony\Component\Debug\Exception\FatalThrowableError
Class 'Symfony\Bridge\PsrHttpMessage\Factory\DiactorosFactory' not found

Discovered that Symfony recently removed support for Diactoros:

Per the current Symfony PSR 7 Bridge docs Diactoros is no longer referenced. Instead they recommend nyholm/psr7.

Steps To Reproduce:

Follow the instructions to take advantage of PSR7 Requests.

Observe the deprecation (and likely abandonment warning as Zend Diactoros is now an archived repo and responsibility has moved to https://github.com/laminas/laminas-diactoros for future development of Diactoros).

@ivannovak

This comment has been minimized.

Copy link
Author

@ivannovak ivannovak commented Jan 3, 2020

PR to Framework: #31018
PR to Docs: laravel/docs#5703

@GrahamCampbell

This comment has been minimized.

Copy link
Member

@GrahamCampbell GrahamCampbell commented Jan 4, 2020

Just to be clear, this drop only happened in v2 of the symfony component, and not v1? Laravel 6 only says to use ^1.2, so users should be fine.

In Laravel 7 we can change this to ^2.0 and delete the remaining zend code after your 6.x PR is merged.

@ivannovak

This comment has been minimized.

Copy link
Author

@ivannovak ivannovak commented Jan 4, 2020

Correct.

I got snagged by the lack of a version specified in the composer require... line in the docs.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.