Skip to content
This repository has been archived by the owner. It is now read-only.

asl checkbox flashes for a second and then disappears #27

Closed
sloucher opened this issue Feb 14, 2016 · 10 comments

Comments

@sloucher
Copy link

commented Feb 14, 2016

Asl checkbox flashes for a second and then disappears. Couldn't find it again. I've disabled all add-ons other than greasemonkey.

@ekeyte

This comment has been minimized.

Copy link

commented Feb 15, 2016

I am also having this issue.

@CheeseburgerWithFries

This comment has been minimized.

Copy link

commented Feb 15, 2016

I'm experiencing this issue as well.

I had been using 0.3.9 for about ten months (May '15) with no problems and used the same cautious search settings for that period (7 second delay / 70 results per search). Last week my account was disabled at about the same time someone opened an issue here about how they were detected and disabled as well.

I was able to regain access to my account after a couple days without admitting to the caretakers/support that I was using an add-on, but that's when I began experiencing this issue. I was still using 0.3.9 when this started.

I updated to 0.4.4.4 (current master) a couple days ago, but that did not correct the issue. The checkbox is still flashing up for a second and then disappearing.

Due to the recent issues people are having, I'd guess that Fetlife made some updates to the site code or their add-on detection last week, but I do not have evidence to support this.

Running on Windows 8.1, Chrome Version 48.0.2564.109 m (64-bit) with Tampermonkey v3.12.58.

@ljohnso16

This comment has been minimized.

Copy link

commented Feb 17, 2016

I'm assuming because I really don't know how fet is checking or the script is injecting but:
they must be adding an extra JS check that looks for the class names of the ASL extra area, then clears it with more js? this would make sense from the "flashing effect", we see the page load finish, then Greasemonkey injects, then fet removes?

Is there anyway, we can make the IDs and class names unique on every load?

@bgood66

This comment has been minimized.

Copy link

commented Feb 20, 2016

I have a same problem here !!

@bluehatter

This comment has been minimized.

Copy link

commented Feb 24, 2016

Good to know I'm not the only one having this problem. With the "extended" version I have different experiences on my PC and laptop... On my PC, which is currently running Windows 7 with Firefox, nothing appears at all on Fetlife, but on my laptop (which has Windows 10) a check box will briefly appear and then disappear.

With the classic version of the script, the not "extended" version, on both computers some text that says "ASL search?" appears at the top of the web page but there is nothing to click on, it's just text. Both things happen on Chrome as well.

I also had my account temporarily deactivated around a week or so ago and sent an E-mail asking what was going on. I never got any reply but my account was active again the next morning. I never thought about it, but it was after this that the script stopped working so it could very well be that Fetlife increased security or something.

It's a shame, really. I really enjoyed this script. Thanks to the script I was able to make a couple local friends and I liked being able to find local people that shared some of my interests to chat with. I really miss the script...

@meitar

This comment has been minimized.

Copy link
Owner

commented Feb 24, 2016

This is fixed in f7ad8b2, released as version 0.4.5. If you have a recent version of this script, it will automatically update. If you don't, you should uninstall and re-install this script by clicking here.

For those curious, have a look at the precise block that fixes the issue. (Well, works around the issue, anyway, since the "fix" is really to tell FetLife to stop being dicks, but, LMAO, y'know….)

@quasi8

This comment has been minimized.

Copy link

commented Feb 24, 2016

How about fetlife's detection of the script? Has this been addressed also?

@meitar

This comment has been minimized.

Copy link
Owner

commented Feb 25, 2016

How about fetlife's detection of the script? Has this been addressed also?

Only one way to find out, and of the two of us, I'm not the one who uses FetLife. ;)

@acasarsa

This comment has been minimized.

Copy link

commented Mar 12, 2016

I am having this problem too and I did re-install the script. I never used it before (have never gotten to use it yet)

meitar added a commit that referenced this issue Mar 12, 2016
@meitar

This comment has been minimized.

Copy link
Owner

commented Mar 12, 2016

Try updating to version 0.4.6, which contains another attempted fix for this issue that works for Google Chrome users. Seems to work in my testing.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
9 participants
You can’t perform that action at this time.