Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

VTune Amplifier command line does not work #2725

Closed
edbennett opened this issue Dec 5, 2017 · 1 comment
Closed

VTune Amplifier command line does not work #2725

edbennett opened this issue Dec 5, 2017 · 1 comment
Labels

Comments

@edbennett
Copy link

@edbennett edbennett commented Dec 5, 2017

  • Microsoft Windows [Version 10.0.17046.1000]
  • I'm attempting to run the VTune Amplifier command-line tool (part of the Intel Parallel Studio). I've successfully installed Parallel Studio, and as of upgrading to the Insider build I'm successfully able to run the compilers. However, running amplxe-cl returns the error: amplxe-cl: error while loading shared libraries: libamplxe_dicer2_plugin_tpss_2.20.so: cannot enable executable stack as shared object requires: Invalid argument.
  • Repro steps
    • Install Intel Parallel Studio 2018
    • Source the relevant variables (source ~/intel/vtune_amplifier/amplxe-vars.sh intel64)
    • Run amplxe-cl
  • What happens:
    • The error message amplxe-cl: error while loading shared libraries: libamplxe_dicer2_plugin_tpss_2.20.so: cannot enable executable stack as shared object requires: Invalid argument appears.
  • What's wrong / what should be happening instead:
    • A usage message appears detailing the options available
  • Strace
@therealkenc

This comment has been minimized.

Copy link
Collaborator

@therealkenc therealkenc commented Dec 5, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.