Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Mono crashes when attempting to insert unicode accented letter in a text field #17029

Open
cleinias opened this issue Sep 24, 2019 · 0 comments

Comments

@cleinias
Copy link

commented Sep 24, 2019

I am using Subtitle Edit for Linux, versions 3.5.10 on an up-to-date Archlinux system. The issue initially arose when trying to insert the letter "è" (i.e. " egrave # LATIN SMALL LETTER E WITH GRAVE") with cut and paste from another application. I have later confirmed with other accented letters. Mono crashes with the stack trace attached below.
Direct insertion from the keyboard using a dead/compose key (I have a US keyboard) ignores the accent and results in a simple "e".

Steps to Reproduce

  1. Open Subtitle Edit
  2. Open a subtitle file (.srt)
  3. Paste an accented letter into any subtitle

Current Behavior

Insertion is refused and mono crashes with the attached log

Expected Behavior

Correct character insertion at paste point

On which platforms did you notice this

[ ] macOS
[x ] Linux
[ ] Windows

Version Used:
Mono JIT compiler version 6.0.0 (makepkg/f8ea05bddcb Wed 11 Sep 2019 12:21:58 AM CEST)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
Interpreter: yes
LLVM: supported, not enabled.
Suspend: hybrid
GC: sgen (concurrent by default)

Stacktrace

SubtitleeditStackTrace

`

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.