New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

battop.ml is not working on 4.01 #434

Closed
Drup opened this Issue Sep 4, 2013 · 3 comments

Comments

Projects
None yet
3 participants
@Drup
Contributor

Drup commented Sep 4, 2013

The error message is the following :

File "~/.opam/4.01.0/lib/batteries/battop.ml", line 1:
Error: The external function `caml_ba_dim_1' is not available
@hcarty

This comment has been minimized.

Show comment
Hide comment
@hcarty

hcarty Sep 4, 2013

Contributor

As mentioned in the utop bug this sounds like a build or environment issue. I just created a fresh opam install of OCaml 4.01.0rc1 + Batteries. battop.ml works in this setup from utop and the raw OCaml toplevel. This is on a 64bit Linux.

Contributor

hcarty commented Sep 4, 2013

As mentioned in the utop bug this sounds like a build or environment issue. I just created a fresh opam install of OCaml 4.01.0rc1 + Batteries. battop.ml works in this setup from utop and the raw OCaml toplevel. This is on a 64bit Linux.

@Drup

This comment has been minimized.

Show comment
Hide comment
@Drup

Drup Sep 4, 2013

Contributor

Same as with utop, a remove/install fixed it, but I have no idea how it ended up like this.

Contributor

Drup commented Sep 4, 2013

Same as with utop, a remove/install fixed it, but I have no idea how it ended up like this.

@Drup Drup closed this Sep 4, 2013

@arj

This comment has been minimized.

Show comment
Hide comment
@arj

arj commented Jan 27, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment