Permalink
Fetching contributors…
Cannot retrieve contributors at this time
41 lines (37 sloc) 1.42 KB
opam-version: "2.0"
maintainer: "Louis Gesbert <louis.gesbert@ocamlpro.com>"
authors: "Louis Gesbert <louis.gesbert@ocamlpro.com>"
homepage: "https://github.com/AltGr/opam-user-setup"
bug-reports: "https://github.com/AltGr/opam-user-setup/issues"
license: "ISC"
dev-repo: "git+https://github.com/AltGr/opam-user-setup.git"
build: [make]
depends: [
"ocaml" {>= "4.00"}
"ocamlfind" {build}
"cmdliner"
"re"
]
depopts: ["tuareg" "merlin" "ocp-indent" "ocp-index"]
post-messages: [
"To setup or update your editors, run 'opam user-setup install'."
{success}
]
tags: "org:ocamlpro"
synopsis:
"Helper for the configuration of editors for the use of OCaml tools"
description: """
This tool knows about several editors, and several OCaml editing tools existing
as opam packages. It automates the configuration of these editors, providing
base templates when appropriate, and suitably installing the editing tools in
the editor's configuration.
For example, it will configure your emacs or Vim to indent OCaml files using
[ocp-indent](http://www.typerex.org/ocp-indent.html) if you have that installed.
Opam-user-setup is designed to be suitable both to beginners not wanting to be
bothered with configuration files, and to people who manage them carefully.
It's customisable and reversible."""
flags: plugin
url {
src: "https://github.com/OCamlPro/opam-user-setup/archive/0.6.tar.gz"
checksum: "md5=223d53b4d6bd61b5f4fee9cad128573d"
}