Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#704 - brcmfmac / Raspberry Pi 3 / wifi not working / adhoc and 80211s-mode #6594

Closed
openwrt-bot opened this issue Apr 11, 2017 · 5 comments
Closed
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Apr 11, 2017

bittorf:

tested with a snapshot-image and a selfcompiled with r3923
wifi in adhoc mode or 80211s-mode ist not working. Messages in
syslog are the same. wifi-scanning works (iw dev wlan0 scan).

root@LEDE:~ :) dmesg | grep -i brcm [ 14.341639] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Aug 29 2016 20:48:16 version 7.45.41.26 (r640327) FWID 01-4527cfab [ 14.387220] usbcore: registered new interface driver brcmfmac

root@LEDE:~ wifi
root@LEDE:~ logread
Sun Apr 9 04:04:02 2017 daemon.notice netifd: Interface 'wlan' is now down
Sun Apr 9 04:04:02 2017 daemon.notice netifd: Interface 'wlan' is disabled
Sun Apr 9 04:04:03 2017 daemon.notice netifd: radio0 (5094): command failed: No error information (-524)
Sun Apr 9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: No error information (-524)
Sun Apr 9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: Not supported (-95)
Sun Apr 9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: I/O error (-5)
Sun Apr 9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: Too many open files in system (-23)
Sun Apr 9 04:04:04 2017 daemon.notice netifd: radio0 (5131): command failed: Too many open files in system (-23)
Sun Apr 9 04:04:04 2017 daemon.notice netifd: radio0 (5131): Device setup failed: INTERFACE_CREATION_FAILED
Sun Apr 9 04:04:04 2017 daemon.notice netifd: radio0 (5131): WARNING: Variable 'interfaces' does not exist or is not an array/object

root@LEDE:~ uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.country='US'
wireless.radio0.channel='5'
wireless.radio0.path='platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
wireless.radio0.hwmode='11g'
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device='radio0'
wireless.@wifi-iface[0].network='wlan'
wireless.@wifi-iface[0].mode='adhoc'
wireless.@wifi-iface[0].bssid='02:ca:ff:ee:ba:be'
wireless.@wifi-iface[0].macaddr='b8:27:eb:14:63:ea'
wireless.@wifi-iface[0].ssid='ffintern.2GHz'

root@LEDE:~ :) ip address show dev wlan0
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc prio state DOWN group default qlen 1000
link/ether b8:27:eb:14:63:ea brd ff:ff:ff:ff:ff:ff
inet 10.63.5.1/8 brd 10.255.255.255 scope global wlan0
valid_lft forever preferred_lft forever

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Apr 23, 2017

Noltari:

I could narrow it down to commit 8301e61:
https://git.lede-project.org/?p=source.git;a=commit;h=8301e613655c2d95fa5430a1a57d92d966fdc70b

If I revert this commit it works.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Apr 23, 2017

manusfreedom:

Same problem as https://bugs.lede-project.org/index.php?do=details&task_id=664

I think we need a more global fix.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Apr 24, 2017

Noltari:

Hi Manus,

Any ideas?

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented May 13, 2017

valdi74:

Vittorio's patch in https://bugs.lede-project.org/index.php?do=details&task_id=664 resolves this issue on Rasperry Pi 3

Waldek.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant