Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3987 - Autonegotiation stopped working #8982

Closed
openwrt-bot opened this issue Aug 22, 2021 · 1 comment
Closed

FS#3987 - Autonegotiation stopped working #8982

openwrt-bot opened this issue Aug 22, 2021 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Aug 22, 2021

Technocrat:

Supply the following if possible:

  • Device problem occurs on ASUS RT-AC65P
  • Software versions of OpenWrt 21.02.0-rc3
  • Plug WAN port with two-pair cable of an ISP (100Mb/s)
    Execute cmd:
    ethtool wan

Speed: 1000Mb/s
Duplex: Full
The connection is not working due to the incorrect speed.

Connect the same cable to a switch, and then the router to the same switch. Or execute the command:
ethtool -s wan speed 100 autoneg off duplex full
After that the connection is properly established with proper speed:
ethtool wan

Speed: 100Mb/s
Duplex: Full

Autonegotiation was working properly about a year and a half ago, so there was some changes made in the code that affected it. It also working with no issue with stock firmware.

@darkblaze69
Copy link

@darkblaze69 darkblaze69 commented Feb 20, 2022

full duplicate for #8981

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

3 participants