Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#4168 - unknown configuration item 'iapp_interface' #9154

Open
openwrt-bot opened this issue Dec 1, 2021 · 1 comment
Open

FS#4168 - unknown configuration item 'iapp_interface' #9154

openwrt-bot opened this issue Dec 1, 2021 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Dec 1, 2021

henkv:

Hostapd refuses start when the option 'iapp_interface 'br-lan' is set.
It fails with the following error:

Wed Dec 1 13:18:39 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Wed Dec 1 13:18:39 2021 daemon.err hostapd: Line 48: unknown configuration item 'iapp_interface'
Wed Dec 1 13:18:39 2021 daemon.err hostapd: 1 errors found in configuration file '/var/run/hostapd-phy0.conf'
Wed Dec 1 13:18:39 2021 daemon.err hostapd: Failed to set up interface with /var/run/hostapd-phy0.conf
Wed Dec 1 13:18:39 2021 daemon.notice netifd: radio0 (2867): Command failed: Invalid argument
Wed Dec 1 13:18:39 2021 daemon.notice netifd: radio0 (2867): Device setup failed: HOSTAPD_START_FAILED

My system is a TP-Link re200v1. And the installed software is:
OpenWrt SNAPSHOT, r18164-8f45849876
hostapd - 2021-05-22-b102f19b-51

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Dec 2, 2021

henkv:

It looks like the IAPP functionality is removed from hostapd. See: http://w1.fi/cgit/hostap/commit/?id=018edec9b2bd3db20605117c32ff79c1e625c432

This option should also be removed from the OpenWrt Wiki page.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant