New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong dvfs settings on all SY8113B equipped H3 Xunlong boards #1

Open
ThomasKaiser opened this Issue Nov 10, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@ThomasKaiser

ThomasKaiser commented Nov 10, 2016

I hope you're the guys responsible for tweaking fex settings for Xunlong OS images? If that's true please keep in mind that all your OS images for the smaller Orange Pi boards use wrong settings that lead to

  • overheating
  • killing CPU cores instead of throttling (applies also to the stuff for larger Orange Pi boards)
  • lower performance than necessary (applies also to the stuff for larger Orange Pi boards)

For a comparison please see here, Changes for cooler_table, ths_para and especially dvfs_table are required. OPi Zero runs perfectly fine at 1200 MHz and with better cooler_table settings killing of CPU cores can also be prevented (important since the outdated kernel you use contains no fix to bring back killed CPU cores).

Please fix this immediately, at least before folks like Michael Larabel grab an OPi Zero and start to run Phoronix test suite benchmarks with your OS image since results will be horrible and the whole world laughs again about Orange Pis being overheating and slow.

@ThomasKaiser

This comment has been minimized.

Show comment
Hide comment
@ThomasKaiser

ThomasKaiser Nov 10, 2016

Also your 3.4.39 kernel shows the insane kswapd0 issue:

bildschirmfoto 2016-11-10 um 11 49 47

With the default Lubuntu 14.04 image now my Orange Pi Zero idles at above 70°C and the first CPU core has been killed directly at boot!

bildschirmfoto 2016-11-10 um 11 51 22

Also your 3.4.39 kernel shows the insane kswapd0 issue:

bildschirmfoto 2016-11-10 um 11 49 47

With the default Lubuntu 14.04 image now my Orange Pi Zero idles at above 70°C and the first CPU core has been killed directly at boot!

bildschirmfoto 2016-11-10 um 11 51 22

@UmutAlihan

This comment has been minimized.

Show comment
Hide comment
@UmutAlihan

UmutAlihan Feb 2, 2017

Is there any solution to this yet???

Is there any solution to this yet???

@ThomasKaiser

This comment has been minimized.

Show comment
Hide comment
@ThomasKaiser

ThomasKaiser Feb 2, 2017

Is there any solution to this yet???

Of course. Use community's work: https://www.armbian.com/download/

Is there any solution to this yet???

Of course. Use community's work: https://www.armbian.com/download/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment