Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bug when exporting report #4035

Closed
anonymous-piwik-user opened this Issue · 5 comments

3 participants

Anonymous Piwik user Matthieu Aubry Benaka
Anonymous Piwik user

Hi!
We have discovered two bugs when we like to export reports.
Case no 1
I can not export any reports when I use a date range and the parameter &flat=1. Here's what I do:
1. I go to the Entry Page report.
2. I select a date range, for example July 1st 2012 to July 1st 2013.
3. In the url I add the parameter &flat=1. I do this because I want the report to include all subpages.
4. I get an error message and no statistics are displayed: "There is no data for this report"
My intention is to export this report to TSV Excel but it is no use clicking on the export icon as no statistics are presented.
Here's an example of the url:
http://piwik.vgregion.se/index.php?module=CoreHome&action=index&date=2012-07-01,2013-07-01&period=range&idSite=32#module=Actions&action=indexEntryPageUrls&date=2012-07-01,2013-07-01&period=range&idSite=32&flat=1

Case no 2
I can not export the report after using the cog wheel tool.
1. I go to the Entry Page report.
2. I select a date range, for example July 1st 2012 to July 1st 2013.
3. I click on the cog wheel icon and select "Make it flat"
4. I get an error message "There is no data for this report".
My intention is to export this report to TSV Excel but it is no use clicking on the export icon as no statistics are presented.

I would like to be able to export all subpages when I select a date range.

Do you have any solution for this? Grateful for any help as reports are often used in our organisation. Thanks in advance!
Best regards,
E

Keywords: export reports, cog wheel, flat reports

Anonymous Piwik user

I was trying to get a similar export but typing the url directly:
http://demo.piwik.org/index.php?module=API&method=Actions.getDownloads&format=TSV&idSite=7&period=range&date=2013-07-09,2013-07-22&flat=1&translateColumnNames=1&language=en&filter_limit=100

and I get this:

Error: The date '2013-07-09' is not a correct date range. It should have the following format: 'lastN', 'previousN', 'YYYY-MM-DD,YYYY-MM-DD'.```

If  I set the flat parameter to 0 I get the right results:
http://demo.piwik.org/index.php?module=API&method=Actions.getDownloads&format=TSV&idSite=7&period=range&date=2013-07-09,2013-07-22&flat=1&translateColumnNames=1&language=en&filter_limit=100

Hope this helps to find the cause.
Regards,
Cristina
Matthieu Aubry
Owner

Thanks for the report.

Anonymous Piwik user

Hi again!
Another great feature would be that the exported report shows more than 100 rows.

It would be great if it was possible to choose how many rows the report should include, for example 'All rows, 3000, 1000, 500, 400, 300, 200, 100'.

Hope it is not too troublesome to fix! You can be sure this would be appreciated greatly by our users who often export reports.
Best regards,
E

Benaka
Collaborator

The "There is no data for this report." and the 'incorrect date range' bugs are both fixed in git. It's also possible to export more than 100 rows. All of this will be in Piwik 2.0 and the bug fixes will be in 1.12.1.

Anonymous Piwik user

Fanstastic! Well done and big THANKS!

Anonymous Piwik user anonymous-piwik-user added this to the 2.0 - Piwik 2.0 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.