New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Improve "init" command #31

Closed
ivankravets opened this Issue Nov 30, 2014 · 2 comments

Comments

Projects
None yet
1 participant
@ivankravets
Member

ivankravets commented Nov 30, 2014

From pull #29 @bettabacon

This was quite messy though. It installed a ./lib, ./src, and platformio.ini without asking me where. I'll move these directories and setup file elsewhere, and try to get

platformio init command initialises empty project within the current folder where you are stayed. See details here http://docs.platformio.ikravets.com/en/latest/userguide/cmd_init.html

Do you have any propositions how to improve the behaviour of this command? I have the next propositions:

  1. Add additional option to this command platformio init -d %path_to_project_dir%
  2. When that option is not specified, then show a warning message that PlatformIO is going to create ./lib, ./src and platformio.ini in the current "shell" directory.

@ivankravets ivankravets self-assigned this Nov 30, 2014

@ivankravets ivankravets added this to the 1.0.0 milestone Nov 30, 2014

@ivankravets

This comment has been minimized.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 1, 2014

@ivankravets ivankravets removed this from the 1.0.0 milestone Feb 11, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment