Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Contact missing in Adressbook #7117

Open
Taste-IT opened this issue Dec 18, 2019 · 5 comments
Open

Contact missing in Adressbook #7117

Taste-IT opened this issue Dec 18, 2019 · 5 comments
Labels

Comments

@Taste-IT
Copy link

@Taste-IT Taste-IT commented Dec 18, 2019

Hi,
from yesterday to now i miss most of my contacts in Tine20. These are not in the WebGUI and on my Smartphone too. I checked DB adressbook and all are there. I set Loglevel 7, but no information about that. Any idea to solve this?
Tine 2019.08.3 is installed
thx

@pschuele

This comment has been minimized.

Copy link
Member

@pschuele pschuele commented Dec 19, 2019

hi,
you could check the records in the addressbook table: do they have is_deleted = 1? which container_id is set?

@Taste-IT

This comment has been minimized.

Copy link
Author

@Taste-IT Taste-IT commented Dec 19, 2019

Hi,
and thx for fast replying. Yes is_deleted value is set to 1 and container id is set to 5. iam not aware of deleting such a mass of contacts. how can i restore them? Simply changing the is_deleted value to 0 = zero?
thx

@pschuele

This comment has been minimized.

Copy link
Member

@pschuele pschuele commented Dec 19, 2019

yes, just setting is_deleted = 0 should restore them. you could also check the timemachine_modlog table (with the record_id + application_id), which client deleted the records. maybe it was a buggy client via ActiveSync or cardDAV?

@Taste-IT

This comment has been minimized.

Copy link
Author

@Taste-IT Taste-IT commented Dec 19, 2019

Hi,
ok sounds good. I looked into modlog and wonder why on same second an ActiveSync Process and TineBase_Server_Json - deleted the contact, than another conatact was deleted by update_script and other only by Active Sync Device. Most of delation happens on same second. Could this be an hack?

@JPRuehmann

This comment has been minimized.

Copy link

@JPRuehmann JPRuehmann commented Dec 20, 2019

Hä?
What are you talking about? how can I see/reset the deleted Value.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.