Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
127 lines (123 sloc) 3.29 KB
# ATTENTION: Most of this file is generated by omd/packages/python-modules/Makefile
[[source]]
url = "https://pypi.python.org/simple"
verify_ssl = true
name = "pypi"
[dev-packages]
pytest = "*"
pytest-cov = "*"
pytest-mock = "*"
"beautifulsoup4" = "*"
dill = "*"
bandit = "*"
lxml = "*"
pylint = "*"
pyenchant = "*"
yapf = "==0.26.0" # Keep 0.26.0 for the moment because 0.27.0 needs whole code base reformatting or config change
docker = "*"
astroid = "*"
mock = "*"
mockldap = "*"
isort = "*"
freezegun = "*"
compiledb = {path = "./omd/packages/python-modules/src/compiledb-10a1da2.tar.gz"} # We have to use a snapshot, a version which works for us has not been released yet. :-/
[packages]
setuptools_scm = "==3.1.0"
pysphere = "==0.1.7"
pyasn1 = "==0.4.4"
pyasn1-modules = "==0.2.2"
pycryptodomex = "==3.6.6"
ordereddict = "==1.1"
ply = "==3.11"
pysmi = "==0.3.2"
pysnmp = "==4.4.4"
snmpsim = "==0.4.6"
setuptools-git = "==1.2"
pymssql = "==2.1.3"
python-ldap = "==3.1.0"
simplejson = "==3.16.0"
mysqlclient = "==1.3.13"
psycopg2 = "==2.7.6.1" # This is actually a lie: We ship 2.6.2, but installation fails for PostgreSQL > 9. Alas, 2.7 removed support for clients < 9.1. >:-(
dicttoxml = "==1.7.4"
pycparser = "==2.19"
enum34 = "==1.1.6"
cffi = "==1.11.5"
Pillow = "==5.3.0"
reportlab = "==3.5.9"
PyPDF2 = "==1.26.0"
npyscreen = "==4.10.5"
psutil = "==5.4.7"
six = "==1.11.0"
ipaddress = "==1.0.22"
netifaces = "==0.10.7"
dnspython = "==1.15.0"
# python-ad = "==0.9" This seems to be dead and is not on PyPi!
idna = "==2.7"
requests = { version = "==2.20.1", extras = ["security"] }
pbr = "==5.1.0"
asn1crypto = "==0.24.0"
cryptography = "==2.4.1"
pyOpenSSL = "==18.0.0"
paramiko = "==2.4.2"
pyghmi = "==1.2.14"
certifi = "==2018.10.15"
chardet = "==3.0.4"
urllib3 = "==1.24.1"
pykerberos = "==1.2.1"
requests-kerberos = "==0.12.0"
tinkerforge = "==2.1.19"
bcrypt = "==3.1.4"
PyNaCl = "==1.3.0"
typing = "==3.6.6"
scandir = "==1.9.0"
pathlib2 = "==2.3.2"
python-dateutil = "==2.7.5"
python-snap7 = "==0.10"
rrdtool = "==0.1.14" # Actually we ship the binding which comes with rrdtool itself...
PyJWT = "==1.6.4"
SecretStorage = {version = "==2.3.1", markers = "sys_platform == 'linux2' and python_version < '3.5'"}
adal = "==1.2.0"
azure-nspkg = "==3.0.2"
azure-common = "==1.1.16"
azure-mgmt-nspkg = "==3.0.2"
isodate = "==0.6.0"
oauthlib = "==2.1.0"
requests-oauthlib = "==1.0.0"
msrest = "==0.6.1"
# use azure-mgmt-monitor 0.4.0 and its dependency
# msrestazure 0.4.34 since the monitor version 0.5.0
# will not deliver all metrics.
msrestazure = "==0.4.34"
azure-mgmt-monitor = "==0.4.0"
azure-mgmt-resource = "==2.0.0"
azure-mgmt-compute = "==4.3.1"
configparser = "==3.5.0"
entrypoints = "==0.2.3"
keyring = "==15.1.0"
Werkzeug = "==0.14.1"
passlib = "==1.7.1"
docutils = "==0.14"
futures = "==3.2.0"
jmespath = "==0.9.3"
botocore = "==1.12.43"
s3transfer = "==0.1.13"
boto3 = "==1.9.42"
cachetools = "==3.0.0"
rsa = "==4.0"
google-auth = "==1.6.1"
PyYAML = "==5.1"
websocket_client = "==0.54.0"
kubernetes = "==8.0.0"
# Has been added for jira notification plugin
defusedxml = "==0.5.0"
requests-toolbelt = "==0.9.1"
jira = "==2.0.0"
# Has been added for opsgenie notification plugin
opsgenie-sdk = "==0.3.1"
pytz = "==2019.1"
fancycompleter = "==0.8"
wmctrl = "==0.3"
pdbpp = "==0.10.0"
PySnooper = "==0.0.31"
[requires]
python_version = "2.7"
You can’t perform that action at this time.