New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WYSIWYG (rich text) breaks inlinecode in table. #756

Closed
szczurmys opened this Issue Jun 24, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@szczurmys
Contributor

szczurmys commented Jun 24, 2015

Hi.

I wrote the text in plain text,
001a_before_plain_text

this works fine
001b_parse_plain_text

but when I switched to rich text
002_rich_text

then WYSIWYG breaks inlinecode.
003_breaks_down_plain_text

That is an error, whether inlinecode in table can not be multiline?

@amolenaar amolenaar added this to the Next release milestone Jun 24, 2015

@amolenaar

This comment has been minimized.

Show comment
Hide comment
@amolenaar

amolenaar Jun 24, 2015

Collaborator

I think it's a limitation of the current rich text editor implementation.
A.k.a. a bug :)

Collaborator

amolenaar commented Jun 24, 2015

I think it's a limitation of the current rich text editor implementation.
A.k.a. a bug :)

@szczurmys

This comment has been minimized.

Show comment
Hide comment
@szczurmys

szczurmys Jun 24, 2015

Contributor

In the file fitnesse\resources\wysiwyg\wysiwyg.js,
in function handleLine,
in line 2435,

I added && !inCodeBlock() condition in if statement

        if (inTable() && !inEscapedText() && !inHashTable() && !inCodeBlock()) {
            handleTableCell(-1);
        }

and now inlineCode looks fine.

inlinecodelooksfine

Contributor

szczurmys commented Jun 24, 2015

In the file fitnesse\resources\wysiwyg\wysiwyg.js,
in function handleLine,
in line 2435,

I added && !inCodeBlock() condition in if statement

        if (inTable() && !inEscapedText() && !inHashTable() && !inCodeBlock()) {
            handleTableCell(-1);
        }

and now inlineCode looks fine.

inlinecodelooksfine

@amolenaar amolenaar closed this in bb440c5 Jun 24, 2015

@amolenaar

This comment has been minimized.

Show comment
Hide comment
@amolenaar

amolenaar Jun 24, 2015

Collaborator

Thanks for investigating. I added a test along with the fix, so it remains working.

Collaborator

amolenaar commented Jun 24, 2015

Thanks for investigating. I added a test along with the fix, so it remains working.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment