New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Vagrant 1.9.0 / OSX 10.12.1 - Ignoring eventmachine-1.0.9.1 because its extensions are not built #292

Closed
nervo opened this Issue Nov 30, 2016 · 8 comments

Comments

Projects
None yet
6 participants
@nervo

nervo commented Nov 30, 2016

I have just tried to install landrush on a fresh vagrant 1.9.0 install on OSX 10.12.1
Nothings to notice in particular except "Building native extensions"

$ vagrant plugin install landrush --verbose
Installing the 'landrush' plugin. This can take a few minutes...
Fetching: eventmachine-1.0.9.1.gem (100%)
Building native extensions.  This could take a while...
Fetching: landrush-ip-0.2.5.gem (100%)
Fetching: win32-process-0.8.3.gem (100%)
Fetching: rubydns-0.8.5.gem (100%)
Fetching: landrush-1.1.2.gem (100%)

Right after, every vagrant command sends a warning...

$ vagrant ssh
Ignoring eventmachine-1.0.9.1 because its extensions are not built.  Try: gem pristine eventmachine --version 1.0.9.1

... and daemon refuse to start

$ vagrant landrush start
Ignoring eventmachine-1.0.9.1 because its extensions are not built.  Try: gem pristine eventmachine --version 1.0.9.1
$ vagrant landrush status
Ignoring eventmachine-1.0.9.1 because its extensions are not built.  Try: gem pristine eventmachine --version 1.0.9.1
Daemon status: unknown
/Users/[...]/.vagrant.d/data/landrush/run/landrush.pid exists, but process is not running
Check log file: /Users/[...]/.vagrant.d/data/landrush/log/landrush.log

landrush.log is empty...

@Bekt

This comment has been minimized.

Bekt commented Dec 1, 2016

Experiencing the same thing. Reverting back to vagrant 1.8.6 works. Can't tell if this is a vagrant issue or landrush 😕

@nervo

This comment has been minimized.

nervo commented Dec 1, 2016

Embedded ruby version looks like the same in vagrant 1.8.7 and 1.9.0:
2.2.5p319

@designtesbrot

This comment has been minimized.

designtesbrot commented Dec 5, 2016

Reproduced on Ubuntu 14.04 using vagrant 1.9.0 and landrush 1.1.2

@nervo

This comment has been minimized.

nervo commented Dec 5, 2016

Maybe related to this: #295 ?

@hferentschik

This comment has been minimized.

Contributor

hferentschik commented Dec 7, 2016

For now Landrush is not compatible with Vagrant 1.9.0. Vagrant 1.9.0 made quite some substantial internal changes, which we need to look into. Most importantly it does not rely on Bundler anymore.

I am about to release Landrush 1.2.0 which will make Landrush compatible with Vagrant up to 1.8.6, after that we will be looking into getting a Landrush release which aligns with Vagrant 1.9

@jamroks

This comment has been minimized.

jamroks commented Apr 29, 2017

Hi,

I'm experiencing the same issue, thanks for the time you put into maintaining this plugin which is cool
but would be great to have some kind of visibility into the release of the 1.9 vagrant compatibility on vagrant-landrush side . thanks

@rtvenge

This comment has been minimized.

rtvenge commented Aug 1, 2017

I'm not 100% sure what (if any) of these steps fixed this issue, but I was able to get the warning to go away.

  • Updated to Vagrant 1.9.7
  • ran vagrant plugin repair

My thought it was the repair command but I can't know for sure. Hopefully that helps someone out.

@hferentschik

This comment has been minimized.

Contributor

hferentschik commented Aug 31, 2018

I think this issue is out of date. The HEAD of Landrush is now on 2.1.4 and I am not able to reproduce this.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment