RSS feed does not work if there are special chars in the news #90

Closed
phaidon opened this Issue Mar 18, 2012 · 7 comments

Projects

None yet

5 participants

@phaidon
Member
phaidon commented Mar 18, 2012

No description provided.

Member
espaan commented Jun 22, 2012

Hi, on what version is this News 3.0 or the Zk1.2 version News 26x?

Member
espaan commented Nov 30, 2012

See also this forum topic.
http://community.zikula.org/index.php?module=Forum&func=viewtopic&topic=59326&start=15#pid264909

nikp made a change with replacing safehtml with safetext

Member

I had this too with News 3.0.0. It depends on html purifier. If I disable the purifier, the rss feed works!

I don't know if it is an issue of News or Core?

Owner
craigh commented Jan 4, 2013

@nmpetkov wrote (in the forum post)

I solved the problem replacing modifier "safehtml" with "safetext" in file index.tpl in directory themes/RSS/templates/modules/News/user (also in modules/News/templates/rss)

Nikolay can you test if the recent changes to the mobile theme in the core have improved your situation? Also, be sure to check when reverting to "safehtml" (not safetext)

@espaan - should we just convert to safetext in this template? would be a quick fix.

Member
espaan commented Jan 4, 2013

I agree with changing to safetext. It is still safe and it that works better ! It might be that HTML is not so convenient in the RSS templates anyhow and that it should eb more text.

@craigh craigh closed this in b1a1084 Jan 4, 2013
Contributor
nmpetkov commented Jan 4, 2013

safehtml does not work with some spetial charachters. Best solution will be to make new modifier, "safexml". HTML and XML are different in terms of allowed spetial charachters.

Owner
craigh commented Jan 4, 2013

Will leave this for now, since I don't know anything about that stuff. If you do and are willing to code it, please submit PR to core with new plugin and let me know to change News.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment