New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

emu4crt #222

Open
Asnivor opened this Issue Jul 6, 2018 · 1 comment

Comments

@Asnivor
Owner

Asnivor commented Jul 6, 2018

from discord:

[3:34 AM] bumber: Hi there! I'm using MedLaunch with emu4crt (a Mednafen fork running based on 1.21.0-UNSTABLE), and when trying to launch a game, it immediately closes and brings MedLaunch back into focus. Mednafen's stdout seems to give an "Unrecognized argument" error. Here's a pastebin of it:

Starting Mednafen 1.21.0-UNSTABLE
 Build information:
   Compiled with gcc 4.9.4
   Running with MinGW-W64 Runtime 5.0 (alpha - rev. 0) 0000-00-00
   Compiled against zlib 1.2.8, running with zlib 1.2.8(flags=0x00000065)
   Compiled against libiconv 15.1, running with libiconv 15.1
   Compiled against SDL 2.0.8(hg-0:aaaaaaaaaaah), running with SDL 2.0.8(hg-0:aaaaaaaaaaah)
   Running with libsndfile-1.0.28
 Base directory: E:\Desktop\Emulators\emu4crt
 Emulation modules: nes snes pce psx ss pce_fast demo cdplay
 Opening lockfile...
 Loading settings from "E:\Desktop\Emulators\emu4crt\mednafen.cfg"...
  Loaded 6244 valid settings and 0 unknown settings.
Unrecognized argument: ---autosave

[3:35 AM] bumber: I've tried disabling autosave in the configs, and disabling auto-backups and auto-saving for mednafen base config and system config files, but it still gives me that error. Is there any way to remove the autosave argument?(edited)

@Asnivor Asnivor self-assigned this Jul 6, 2018

@Asnivor Asnivor added the bug label Jul 24, 2018

@Asnivor Asnivor added this to Pending in MedLaunch Development Dec 2, 2018

Asnivor added a commit that referenced this issue Dec 4, 2018

@Asnivor

This comment has been minimized.

Owner

Asnivor commented Dec 4, 2018

Turns out the not only affected emu4crt.exe (renamed to mednafen.exe) but normal mednafen when the user is running an old version.

Fixed in dev

@Asnivor Asnivor moved this from Pending to In Lastest DEVBUILD ([dev]) in MedLaunch Development Dec 4, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment