Skip to content
Necessary configurations to get this laptop working with macOS.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
EFI/CLOVER
Library/Extenstions/AirPortAtheros40.kext/Contents
Screenshots
.gitignore
README.md

README.md

ASUS-X75VC-Hackintosh

Screenshot

Notes

Clover config & kexts for macOS Mojave 10.14.3. Please generate some other rom number for SMBIOS if you are gonna use this config. Check this for more details. Since this laptop is hardware-wise similar (except display size) to Asus X550VC & Asus X550CC it might work there too - you would need to disable HDMI patch & possibly play around with platform-id.

Hardware

  • Model: ASUS X75VC-TY056D
  • CPU: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
  • Storage: SSD INTEL SSDSC2KW256G8 256GB + HDD TOSHIBA MQ01ABD075
  • Video: Intel HD Graphics 4000
  • Audio: Realtek ALC269
  • LAN: Qualcomm Atheros, AR8161 Gigabit Ethernet
  • Wifi: Originally some unsupported Realtek, replaced with Qualcomm Atheros, AR9285 Wireless Network Adapter (PCI-Express)
  • RAM: 4GB + 8GB DDR3

BIOS

  • Advanced - USB Configuration - XHCI Pre-Boot Mode {Enabled}
  • Advanced - USB Configuration - Legacy USB Support {Enabled}
  • Boot - Launch CSM {Disabled}
  • Boot - Launch PXE OpRom {Disabled}
  • Security - Secure Boot Control {Disabled}

What's working

  • Hardware accelerated graphics
  • CPU power management
  • Wi-Fi
  • HDMI (video & audio)
  • VGA (well, sort of, I see the image getting mirrored, but I have no control over monitor whatsoever)
  • Brightness control
  • Sound
  • Touchpad (+gestures)
  • USB Ports
  • Ethernet
  • Battery percentage (can't confirm that's working correctly since my battery is dead)
  • Sleep & Wake
  • Microphone
  • FN buttons
  • 3.5mm jack
  • iCloud, iMessage

Bugs/not working

  • Camera (have not intention to look up for a fix)
  • Brightness lowest level is higher that I had on Linux (lazily looking for a fix)

Haven't tested

  • Some FN keys (sound & brightness control works though)
  • hibernatemode anything other than 0
  • Mic via combined jack
  • USB 3

References

You can’t perform that action at this time.