Permalink
Fetching contributors…
Cannot retrieve contributors at this time
47 lines (41 sloc) 1.41 KB
require 'rubygems'
require 'rake'
require 'rdoc/task'
desc 'Default: run unit tests.'
task :default => :test
begin
require 'rspec'
require 'rspec/core/rake_task'
desc 'Run the unit tests'
RSpec::Core::RakeTask.new(:test)
rescue LoadError
task :test do
STDERR.puts "You must have rspec 2.0 installed to run the tests"
end
end
desc 'Generate rdoc documentation'
Rake::RDocTask.new(:rdoc) do |rdoc|
rdoc.rdoc_dir = 'rdoc'
rdoc.options << '--title' << 'JSON Record' << '--line-numbers' << '--inline-source' << '--main' << 'README.rdoc'
rdoc.rdoc_files.include('README.rdoc')
rdoc.rdoc_files.include('lib/**/*.rb')
end
begin
require 'jeweler'
Jeweler::Tasks.new do |gem|
gem.name = "json_record"
gem.summary = %Q{ActiveRecord support for mapping complex documents in a single RDBMS row via JSON serialization.}
gem.email = "brian@embellishedvisions.com"
gem.homepage = "http://github.com/bdurand/json_record"
gem.authors = ["Brian Durand"]
gem.files = FileList["lib/**/*", "spec/**/*", "README.rdoc", "Rakefile", "MIT_LICENSE"].to_a
gem.has_rdoc = true
gem.extra_rdoc_files = ["README.rdoc", "MIT_LICENSE"]
gem.rdoc_options = ["--charset=UTF-8", "--main", "README.rdoc"]
gem.add_dependency('activerecord', '>= 3.0.0')
gem.add_development_dependency('rspec', '>=2.0.0')
gem.add_development_dependency('jeweler')
end
Jeweler::GemcutterTasks.new
rescue LoadError
end