Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OpenTTD company HQ graphics bug in x-ray mode #7650

Closed
Ben79487 opened this issue Jul 12, 2019 · 6 comments

Comments

@Ben79487
Copy link

@Ben79487 Ben79487 commented Jul 12, 2019

I'm using OpenTTD 1.9.2 on Windows 8 64-bit.
I was using x-ray mode (key X) to build bus stations when I realized that the company HQ sprite experiences a weird clipping issue with the station sprite.

I expected that the HQ would be rendered with the shadowed graphic, like town buildings and stations, or that it would be rendered in full color.

The actual result was that the HQ sprite was clipped off by the train station sprite of Cuthill Main.

Steps to reproduce:

  1. Stick your HQ in a town, preferably near tall buildings, or right in front of a train station.
  2. Let your company grow a bit, so the HQ will get taller. (Iterations 1 and 2 don't suffer from this glitch.)
  3. Get into xray mode by pressing [X].
  4. See that the HQ sprite is clipped.

(First image is regular mode, second image is xray mode)
Cuthill   Sundhead Railways, 14th May 1987#1
Cuthill   Sundhead Railways, 14th May 1987

@nielsmh

This comment has been minimized.

Copy link
Contributor

@nielsmh nielsmh commented Jul 12, 2019

Nah that's just how the graphics is designed to look. OpenGFX is means to be exactly compatible with the original graphics from Transport Tycoon Deluxe, and that means it clips sprites the same way too. The bottom of the house you see is part of the "ground sprite" and only the part that gets hidden is part of the "house sprite". It looks bad but it's unfortunately intentional and I'm not sure it can be fixed. (Someone else please chime in on that.)

@Ben79487

This comment has been minimized.

Copy link
Author

@Ben79487 Ben79487 commented Jul 12, 2019

Wait... So the ground sprite, in the case of the "Office blocks", is the pavement texture (the gray one) and the building sprite is the building itself?

@nielsmh

This comment has been minimized.

Copy link
Contributor

@nielsmh nielsmh commented Jul 12, 2019

Exactly. You can see the spritesheet here: https://github.com/OpenTTD/OpenGFX/blob/master/sprites/png/miscellaneous/hq.png
Sprite 53 and 55 in that sheet are the HQ top corner ground and building graphics.

@Ben79487

This comment has been minimized.

Copy link
Author

@Ben79487 Ben79487 commented Jul 12, 2019

Thanks. I'll wait to see if anybody else comments before closing this issue.

@Alberth289346

This comment has been minimized.

Copy link
Contributor

@Alberth289346 Alberth289346 commented Jul 26, 2019

I tried original TTDX graphics (windows version), and I get
Screenshot_20190726_104043
and
Screenshot_20190726_104020

Note that industries do this too. "flat" industries are always drawn, and eg factories do
Screenshot_20190726_104402
and
Screenshot_20190726_104433

So yeah, everything within the contour of the ground plate is always shown.

@LordAro

This comment has been minimized.

Copy link
Member

@LordAro LordAro commented Jul 26, 2019

Yup, feature, not a bug ;)

@LordAro LordAro closed this Jul 26, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.