PostCSS plugin for that changes curse words after ! to !important because why not ?
Clone or download
Latest commit 5f17af3 Jan 12, 2018
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
test add external dep Nov 13, 2017
.editorconfig add ignores Feb 15, 2017
.eslintrc.json add inital release Feb 15, 2017
.gitignore remove yarn-error.log Jul 22, 2017
.npmignore add ignores Feb 15, 2017
.travis.yml fix conflicts and add nyc Jul 20, 2017
README.md Update README.md Jan 12, 2018
index.js add external dep Nov 13, 2017
package.json 2.6.0 Nov 13, 2017
yarn.lock add italian words Nov 13, 2017

README.md

PostCSS Caralho Plugin Travis

Coverage Status npm

PostCSS plugin for that changes curse words after ! to !important because why not ?

.foo {
    top: 20px !fuck;
}
.foo {
    top: 20px !important;
}

You can also choose from many more options in different languages and all of them will become !important after PostCSS does his/her thing.

Why ?

Idk, mainly boredom and the need to write !caralho or !fuck in every stylesheet I own.

I want to add words !

Awesome ! You can create a PR here: https://github.com/SaraVieira/curse-words and these tests and the ones in https://github.com/SaraVieira/babel-plugin-caralho will be generated automatically 🎉

Install

Install from NPM using:

npm i postcss-caralho --save-dev

Or Yarn:

yarn add postcss-caralho --dev

Usage

postcss([ require('postcss-caralho') ])

See PostCSS docs for examples for your environment.

License

WTFPL – Do What the Fuck You Want to Public License.