New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Segmentation fault /opt/xplico/bin/trigcap #1045

Closed
bugcrash opened this Issue Dec 22, 2016 · 9 comments

Comments

Projects
None yet
3 participants
@bugcrash

bugcrash commented Dec 22, 2016

bugcrash@seconion:/opt/xplico/bin$ /opt/xplico/bin/trigcap
trigcap v1.1.0
Part of Xplico Internet Traffic Decoder (NFAT).
See http://www.xplico.org for more information.

Copyright 2007-2011 Gianluca Costa & Andrea de Franceschi and contributors.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

usage: /opt/xplico/bin/trigcap [-v] -f <input_file> -t -b -a -o <output_file> [-h]
-v version
-f input pcap file
-t trigger packet number
-b packet numbers before trigger packet
-a packet numbers after trigger packet
-o output pcap file
-h this help

bugcrash@seconion:/opt/xplico/bin$ gdb -q /opt/xplico/bin/trigcap
Reading symbols from /opt/xplico/bin/trigcap...(no debugging symbols found)...done.
(gdb) r -f ruby -e 'puts "A" * 9024'
Starting program: /opt/xplico/bin/trigcap -f ruby -e 'puts "A" * 9024'
trigcap v1.1.0
Part of Xplico Internet Traffic Decoder (NFAT).
See http://www.xplico.org for more information.

Copyright 2007-2011 Gianluca Costa & Andrea de Franceschi and contributors.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7822943 in _IO_vfprintf_internal (s=, format=,
ap=ap@entry=0x7fffffffb7b8) at vfprintf.c:1661
1661 vfprintf.c: No such file or directory.
(gdb) info reg rdi
rdi 0x4141414141414141 4702111234474983745
(gdb)

@dougburks

This comment has been minimized.

Show comment
Hide comment
@dougburks

dougburks Dec 22, 2016

Contributor

Hi @bugcrash ,

Are you trying to report an issue within Xplico itself? If so, please submit it to the Xplico developers directly.

Per the Xplico wiki:

"Don't hesitate to report bugs to bug[@]xplico.org and/or use the forum."
http://wiki.xplico.org/doku.php?id=xplico

Thanks!

Contributor

dougburks commented Dec 22, 2016

Hi @bugcrash ,

Are you trying to report an issue within Xplico itself? If so, please submit it to the Xplico developers directly.

Per the Xplico wiki:

"Don't hesitate to report bugs to bug[@]xplico.org and/or use the forum."
http://wiki.xplico.org/doku.php?id=xplico

Thanks!

@bugcrash

This comment has been minimized.

Show comment
Hide comment
@bugcrash

bugcrash Dec 22, 2016

@dougburks
Because securityonion is using the code. Why wait for the third party to fix the issue.

bugcrash commented Dec 22, 2016

@dougburks
Because securityonion is using the code. Why wait for the third party to fix the issue.

@dougburks

This comment has been minimized.

Show comment
Hide comment
@dougburks

dougburks Dec 22, 2016

Contributor

I've submitted this to bug@xplico.org on your behalf.

Contributor

dougburks commented Dec 22, 2016

I've submitted this to bug@xplico.org on your behalf.

@dougburks

This comment has been minimized.

Show comment
Hide comment
@dougburks

dougburks Dec 26, 2016

Contributor

No response yet from bug@xplico.org, so I've also posted this to:
http://forum.xplico.org/viewtopic.php?f=4&t=572

Contributor

dougburks commented Dec 26, 2016

No response yet from bug@xplico.org, so I've also posted this to:
http://forum.xplico.org/viewtopic.php?f=4&t=572

@dougburks

This comment has been minimized.

Show comment
Hide comment
@dougburks

dougburks Jan 2, 2017

Contributor

Still no response from bug@xplico.org or http://forum.xplico.org/viewtopic.php?f=4&t=572, so I've emailed Gianluca Costa personally.

Contributor

dougburks commented Jan 2, 2017

Still no response from bug@xplico.org or http://forum.xplico.org/viewtopic.php?f=4&t=572, so I've emailed Gianluca Costa personally.

gnlcosta added a commit to xplico/xplico that referenced this issue Jan 2, 2017

@gnlcosta

This comment has been minimized.

Show comment
Hide comment
@gnlcosta

gnlcosta commented Jan 2, 2017

@bugcrash

This comment has been minimized.

Show comment
Hide comment
@bugcrash

bugcrash Jan 3, 2017

@gnlcosta
still missing snprintf() for -o argument.

bugcrash commented Jan 3, 2017

@gnlcosta
still missing snprintf() for -o argument.

@gnlcosta

This comment has been minimized.

Show comment
Hide comment
@gnlcosta

gnlcosta Jan 3, 2017

Ooops.
Right.
Thanks.

gnlcosta commented Jan 3, 2017

Ooops.
Right.
Thanks.

@dougburks

This comment has been minimized.

Show comment
Hide comment

@dougburks dougburks closed this Jan 30, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment