Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
389 lines (229 sloc) 13.9 KB
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component version
2009-10-20 02:18:15 -0700
2015-08-13 02:02:54 -0700
2009-10-21 09:51:24 -0700
closed
crash
Invalid
jackie.MacOSX@…
jeremyhu@…
Expected
2.5.0
xserver
dev (xorg-server-1.6-apple)

startup x11.app then occurs crash.

Process:         X11.bin [40616]
Path:            /Applications/Utilities/X11.app/Contents/MacOS/X11
Identifier:      org.x.X11
Version:         ??? (???)
Build Info:      X11server-850000~1
Code Type:       X86-64 (Native)
Parent Process:  launchd [312]

Date/Time:       2009-10-20 17:14:20.966 +0800
OS Version:      Mac OS X 10.6.1 (10B504)
Report Version:  6

Interval Since Last Report:          6972 sec
Crashes Since Last Report:           109
Per-App Interval Since Last Report:  -3313 sec
Per-App Crashes Since Last Report:   109
Anonymous UUID:                      31B8FB0E-D7B5-42C6-974D-6C6B83F477DA

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/PrivateFrameworks/PasswordServer.framework/Versions/A/PasswordServer
  Reason: Incompatible library version: PasswordServer requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0

Model: MacBookPro5,2, BootROM MBP52.008E.B00, 2 processors, Intel Core 2 Duo, 2.93 GHz, 4 GB, SMC 1.42f4
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.91.19)
Bluetooth: Version 2.2.1f7, 2 service, 0 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Network Service: Ethernet, Ethernet, en0
Network Service: Parallels Shared Networking Adapter, Ethernet, en2
Network Service: Parallels Host-Only Networking Adapter, Ethernet, en3
Serial ATA Device: ST9320421ASG, 298.09 GB
Serial ATA Device: MATSHITADVD-R   UJ-868
USB Device: USB to Serial Cable, 0x0403  (Future Technology Devices International Limited), 0x6001, 0x06400000
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8217, 0x06110000
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0x24400000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0236, 0x04600000
USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000

jackie.MacOSX@… commented on Oct 20, 2009

error message


jeremyhu@… commented on Oct 20, 2009

  • Description modified

What version of the server? Did you do anything "else" to your system?

The shipping version of libsasl2.dylib has compat version 3.0.0 on SnowLeopard... which makes me think you've replaced /usr/lib/libsasl2.dylib on your system with a bad version.

~ $  otool -L /usr/lib/libsasl2.2.dylib 
/usr/lib/libsasl2.2.dylib:
    /usr/lib/libsasl2.2.dylib (compatibility version 3.0.0, current version 3.15.0)
    /usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 123.0.0)

jeremyhu@… commented on Oct 20, 2009

  • Milestone changed from SnowLeopard to 2.4.1

jeremyhu@… commented on Oct 20, 2009

  • Component changed from x11-apps to xserver

jackie.MacOSX@… commented on Oct 20, 2009

[ jackie ~ ]# otool -L /usr/lib/libsasl2.2.dylib /usr/lib/libsasl2.2.dylib:

/usr/lib/libsasl2.2.dylib (compatibility version 3.0.0, current version 3.15.0) /usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 123.0.0)


jeremyhu@… commented on Oct 20, 2009

Well your crash log says:

Reason: Incompatible library version: PasswordServer requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0

so... something is amiss. Are you playing with environment variables? Run this:

set | grep PATH

jackie.MacOSX@… commented on Oct 21, 2009

yes.

[ jackie ~ ]# set | grep PATH BOOST_BUILD_PATH=/opt/local/share/boost-build DYLD_LIBRARY_PATH=/opt/local/lib/qt3/lib:/Users/jackie/ACE_wrappers/ace:/Users/jackie/ACE_wrappers/lib:/opt/local/lib:/opt/local/lib: LD_LIBRARY_PATH=/Users/jackie/ACE_wrappers/ace:/Users/jackie/ACE_wrappers/lib:/Users/jackie/ACE_wrappers/DDS/lib:/opt/local/lib:/opt/local/lib: MANPATH=/opt/local/share/man:/usr/local/man: PATH=/opt/local/bin:/opt/local/sbin:/opt/local/wireshark:/opt/local/lib/qt3/bin:/Users/jackie/ACE_wrappers/bin:/Users/jackie/ACE_wrappers/TAO/CIAO/bin:/opt/local/bin:/usr/local/bin:/opt/local/rar:/Users/jackie/ACE_wrappers/bin:/Users/jackie/ACE_wrappers/TAO/bin:/Users/jackie/ACE_wrappers/TAO/CIAO/bin:/Users/jackie/ACE_wrappers/DDS/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin PYTHONPATH=/opt/local/lib/python2.5/site-packages


jeremyhu@… commented on Oct 21, 2009

  • Status changed from new to closed
  • Resolution changed from to invalid

DYLD_LIBRARY_PATH and LD_LIBRARY_PATH are your problem. You're forcing the loader to choose a different lib than the one Apple ships in /usr/lib


jackie.MacOSX@… commented on Oct 21, 2009

After execute the "sudo port deactivate cyrus-sasl2 libgsasl giflib jpeg tiff png libpng mesa", then X11 could run normally.


jackie.MacOSX@… commented on Oct 21, 2009

[ jackie ~ ]# ddd [3] 34214 [ jackie ~ ]# Warning:

Name: copy Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

(Annoyed? Try 'Edit->Preferences->General->Suppress X Warnings'!) Warning:

Name: copy Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

Warning:

Name: paste Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

Warning:

Name: paste Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

Warning:

Name: copy Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

Warning:

Name: paste Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

Note: When I run x11 application "ddd" , it should be run "port activate jpeg libpng" to start ddd ...


jackie.MacOSX@… commented on Oct 22, 2009

If it run x11-app "ddd" without execute "port activate jpeg libpng" , I'll got the following error message:

[ jackie xie-mengbangde-macbook-pro ~ ]# ddd dyld: Library not loaded: /opt/local/lib/libjpeg.62.dylib

Referenced from: /opt/local/bin/ddd Reason: image not found

Trace/BPT trap

Note: It still cannot run the X11 from the installed Macports and I got the following error message when run the /opt/local/bin/X [ jackie ~ ]# /opt/local/bin/X launch_msg("CheckIn") IPC failure: Operation not permitted Xquartz: X11.app = /Applications/MacPorts/X11.app/Contents/MacOS/X11 Xquartz: Starting X server: /Applications/MacPorts/X11.app/Contents/MacOS/X11 --listenonly X11.app: main(): argc=2

argv[0] = /Applications/MacPorts/X11.app/Contents/MacOS/X11.bin argv[1] = --listenonly

Waiting for startup parameters via Mach IPC. X11.app: do_start_x11_server(): argc=1

argv[0] = /opt/local/bin/X

Xquartz starting: X.Org X Server 1.6.5-apple2 Build Date: 20091022 (EE) XKB: Couldn't open rules file /opt/local/share/X11/xkb/rules/base (EE) XKB: No components provided for device Virtual core keyboard (EE) XKB: Couldn't open rules file /opt/local/share/X11/xkb/rules/base (EE) XKB: No components provided for device keyboard dyld: Library not loaded: /opt/local/lib/libpng12.0.dylib

Referenced from: /opt/local/bin/wireshark Reason: image not found

dyld: Library not loaded: /opt/local/lib/libpng12.0.dylib

Referenced from: /opt/local/bin/mrxvt Reason: image not found

dyld: Library not loaded: /opt/local/lib/libpng12.0.dylib

Referenced from: /opt/local/bin/mrxvt Reason: image not found

xterm: fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0" Quitting Xquartz... Xquartz: start_x11_server: (ipc/mig) server died [ jackie ~ ]#


jeremyhu@… commented on Oct 22, 2009

Yes... if you remove libjpeg, and ddd uses libjpeg, ddd will cease to work... that is expected.

As mentioned, the problem is that you are setting DYDL_LIBRARY_PATH without understanding how it works. Stop setting that environment variable and things will behave correctly.


jeremyhu@… commented on Oct 22, 2009

And don't run /opt/local/bin/X to start the server, just run your application and let launchd start the server, or just run the .app (/Applications/MacPorts/X11.app)


jackie.MacOSX@… commented on Oct 23, 2009

Replying to jeremyhu@…:

And don't run /opt/local/bin/X to start the server, just run your application and let launchd start the server, or just run the .app (/Applications/MacPorts/X11.app)

Run the /Applications/MacPorts/X11.app will crash too. And as run DDD, it will hang with following error message.

[ jackie ~ ]# Name: xxx Class: XmPushButton Illegal mnemonic character; Could not convert X KEYSYM to a keycode

It seems that the「cyrus-sasl2 libgsasl giflib jpeg tiff png libpng mesa」mac ports does not support X11 now.


jeremyhu@… commented on Oct 23, 2009

No, the problem is your environment variables. Don't set those environment variables which you do not understand. They are causing all your problems.


jackie.MacOSX@… commented on Oct 26, 2009

Do yuo mean thah I should not use applications or libraries from macports ? If I have no set these environment variables for macport , I could not use anything from macports.


jackie.MacOSX@… commented on Oct 26, 2009

I follow your suggestion but it still cannot startup the x11.app from macports, without error message is appear.


jeremyhu@… commented on Oct 26, 2009

This is not the correct location to discuss this issue. Please bring this up on the macports-users mailing list.

http://lists.macosforge.org/mailman/listinfo.cgi/macports-users


jeremyhu@… commented on Oct 26, 2009

And no, I do not mean you shouldn't use MacPorts. What I said explicitly was you should not set these environment variables:

DYLD_LIBRARY_PATH
LD_LIBRARY_PATH

Your setting those is the root of all your problems.


jackie.MacOSX@… commented on Oct 26, 2009

Replying to jeremyhu@…:

And no, I do not mean you shouldn't use MacPorts. What I said explicitly was you should not set these environment variables:

DYLD_LIBRARY_PATH
LD_LIBRARY_PATH

Your setting those is the root of all your problems.

I remark all of the DYLD_LIBRARY_PATH and LD_LIBRARY_PATH environment variables but the X11 from macports still could not to startup normally. ddd is still hanging with such "Class: XmPushButton/Illegal mnemonic character; Could not convert X KEYSYM to a keycode" error message and it could not run normally. Thanks for you help~


jeremyhu@… commented on Oct 27, 2009

Yes, I understand. Those messages pertain to motif and are not produced by anything shipped by XQuartz. Please take this discussion to an appropriate forum (like the macports-users mailing list).

You can’t perform that action at this time.