Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[breaking][deps] Add @babel/runtime as a peer dep #229

Merged
merged 1 commit into from Sep 4, 2019

Conversation

@noratarano
Copy link
Contributor

commented Sep 4, 2019

Summary

Was getting the following error from another repo that didn't have it installed while I was testing version 4.0.0-alpha.1:

FAIL test/index_test.js
  ● compileCSS › returns css

    Cannot find module '@babel/runtime/helpers/interopRequireWildcard' from 'withStyles.js'

      at Resolver.resolveModule (node_modules/jest-resolve/build/index.js:221:17)
      at Object.<anonymous> (node_modules/react-with-styles/lib/withStyles.js:3:31)

We need to add it because @babel/runtime is a peer dep of babel-preset-airbnb. The reason we weren't seeing any errors for this before is because eslint-plugin-jsx-a11y (a dev dep here) had already installed it as a dependency.

Reviewers

@ljharb @lencioni @TaeKimJR @indiesquidge @ahuth @joeuy @majapw

@noratarano noratarano changed the title [deps] Add @babel/runtime as a peer dep [breaking][deps] Add @babel/runtime as a peer dep Sep 4, 2019

@ljharb
ljharb approved these changes Sep 4, 2019
@@ -50,6 +50,7 @@
"@babel/cli": "^7.5.5",
"@babel/core": "^7.5.5",
"@babel/register": "^7.5.5",
"@babel/runtime": "^7.5.5",

This comment has been minimized.

Copy link
@ljharb

ljharb Sep 4, 2019

Collaborator

ideally the dev dep version is an exact match of the peer dep one

This comment has been minimized.

Copy link
@noratarano

noratarano Sep 4, 2019

Author Contributor

@ljharb The issue is that eslint-plugin-jsx-a11y@6.2.3 installs 7.5.5. 🤔 so it always resolves to 7.5.5 anyway. Should we require the peer dep to be 7.5.5 or 7.0.0?

This comment has been minimized.

Copy link
@ljharb

ljharb Sep 4, 2019

Collaborator

Sure, but ^7 will include that too. I think ^7 is the most widely compatible.

@noratarano noratarano force-pushed the nora--babel-runtime branch from 29cfb26 to eb70346 Sep 4, 2019

@noratarano noratarano force-pushed the nora--babel-runtime branch from eb70346 to 1ed04bd Sep 4, 2019

@@ -76,6 +77,7 @@
"sinon-sandbox": "^2.0.5"
},
"peerDependencies": {
"@babel/runtime": "^7.0.0",

This comment has been minimized.

Copy link
@noratarano

noratarano Sep 4, 2019

Author Contributor

@ljharb Now the versions of @babel/runtime are set to ^7.0.0 and they match! PTAL 🙏

@noratarano noratarano merged commit 1558a64 into master Sep 4, 2019

3 checks passed

Tidelift Dependencies checked
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
@noratarano noratarano referenced this pull request Sep 4, 2019

@ljharb ljharb deleted the nora--babel-runtime branch Sep 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.